1142 Maximal Clique (25 分)

1142 Maximal Clique (25 分)

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:
For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:
8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1
Sample Output:
Yes
Yes
Yes
Yes
Not Maximal
Not a Clique
题目大意:Clique是一个所有结点都互相毗连的无向图结点子集,给定图和序列,问是否是Clique,如果是,问是否是Maximal Clique(不可添加其他结点)
分析:先判断给定序列集合内部的点是否相连,若有结点不相连则不是Clique,反之再判断是否是Maximal,判断集合外部结点与集合内部结点的相连情况,若有与所有内部结点均相连的外部结点则不是Clique不是Maximal。

#include<cstdio>
#include<vector> 
using namespace std;
const int maxn = 210;
int Nv, Ne, G[maxn][maxn] = { 0 }, m;
int main() {
	scanf("%d %d", &Nv, &Ne);
	for (int i = 0;i < Ne;++i) {
		int u, v;
		scanf("%d %d", &u, &v);
		G[u][v] = G[v][u] = 1;
	}
	scanf("%d", &m);
	while (m--) {
		int k;
		bool hashTable[maxn] = { false }, isClique = true, isMaximal;
		scanf("%d", &k);
		vector<int> v(k);
		for (int i = 0;i < k;++i) {
			scanf("%d", &v[i]);
			hashTable[i] = true;
		}
		for (int i = 0;i < k - 1;++i) {
			if (isClique == false) break;
			for (int j = i + 1;j < k;++j) {
				if (G[v[i]][v[j]] == 0) {
					isClique = false;
					printf("Not a Clique\n");
					break;
				}
			}
		}
		if (isClique == false) continue;
		for (int i = 1;i <= Nv;++i) {//结点序号从1到Nv
			isMaximal = false;
			if (hashTable[i] == false) {
				for (int j = 0;j < k;++j) {
					if (G[i][v[j]] == 0) {
						isMaximal = true;
						break;
					}
				}
				if (isMaximal == false) {
					printf("Not Maximal\n");
					break;
				}
			}
		}
		if (isMaximal == true) printf("Yes\n");
	}
	return 0;
}

反思:最开始看错题目,以为是相邻两点间是通路,死活不能AC,此外要注意序号的范围。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值