1122 Hamiltonian Cycle (25 分)

1122 Hamiltonian Cycle (25 分)

The “Hamilton cycle problem” is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a “Hamiltonian cycle”.

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2< N <= 200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format “Vertex1 Vertex2”, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V1 V2 … Vn

where n is the number of vertices in the list, and Vi’s are the vertices on a path.

Output Specification:

For each query, print in a line “YES” if the path does form a Hamiltonian cycle, or “NO” if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

题目大意:给出图的信息,判断是不是Hamiltonian Cycle——简单遍历每个点并形成环
分析:如果路径不通(相邻两结点间不存在边)、路径不简单(结点数超过n+1)、不成环(序列中v[0]!=v[n-1])、未经过所有结点(set.size()<n)则No,反之Yes。

#include<iostream>
#include<vector>
#include<set>
using namespace std;
const int maxn = 210;
int G[maxn][maxn] = { 0 };
int n, m, k;
int main() {
	scanf("%d %d", &n, &m);
	for (int i = 0;i < m;++i) {
		int u, v;
		scanf("%d %d", &u, &v);
		G[u][v] = G[v][u] = 1;
	}
	scanf("%d", &k);
	while (k--) {
		int t;
		bool flag = true;//flag表给出的结点是否可通 
		scanf("%d", &t);
		vector<int> v(t);
		set<int> st;
		for (int i = 0;i < t;++i) {
			scanf("%d", &v[i]);
			st.insert(v[i]);
		}
		for (int i = 0;i < t - 1;++i) {
			if (G[v[i]][v[i + 1]] == 0) {
				flag = false;
				break;
			}
		}
		if (flag == false || st.size() != n || v[0] != v[t - 1] || v.size() != n + 1) printf("NO\n");
		else printf("YES\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值