1137 Final Grading (25分) 测试点4答案错误的看过来~

1137 Final Grading (25分)
For a student taking the online course “Data Structures” on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first obtain no less than 200 points from the online programming assignments, and then receive a final grade no less than 60 out of 100. The final grade is calculated by G=(G
​mid−term
​​ ×40%+G
​final
​​ ×60%) if G
​mid−term
​​ >G
​final
​​ , or G
​final
​​ will be taken as the final grade G. Here G
​mid−term
​​ and G
​final
​​ are the student’s scores of the mid-term and the final exams, respectively.

The problem is that different exams have different grading sheets. Your job is to write a program to merge all the grading sheets into one.

Input Specification:
Each input file contains one test case. For each case, the first line gives three positive integers: P , the number of students having done the online programming assignments; M, the number of students on the mid-term list; and N, the number of students on the final exam list. All the numbers are no more than 10,000.

Then three blocks follow. The first block contains P online programming scores G
​p
​​ 's; the second one contains M mid-term scores G
​mid−term
​​ 's; and the last one contains N final exam scores G
​final
​​ 's. Each score occupies a line with the format: StudentID Score, where StudentID is a string of no more than 20 English letters and digits, and Score is a nonnegative integer (the maximum score of the online programming is 900, and that of the mid-term and final exams is 100).

Output Specification:
For each case, print the list of students who are qualified for certificates. Each student occupies a line with the format:

StudentID G
​p
​​ G
​mid−term
​​ G
​final
​​ G

If some score does not exist, output “−1” instead. The output must be sorted in descending order of their final grades (G must be rounded up to an integer). If there is a tie, output in ascending order of their StudentID’s. It is guaranteed that the StudentID’s are all distinct, and there is at least one qullified student.

Sample Input:
6 6 7
01234 880
a1903 199
ydjh2 200
wehu8 300
dx86w 220
missing 400
ydhfu77 99
wehu8 55
ydjh2 98
dx86w 88
a1903 86
01234 39
ydhfu77 88
a1903 66
01234 58
wehu8 84
ydjh2 82
missing 99
dx86w 81

Sample Output:
missing 400 -1 99 99
ydjh2 200 98 82 88
dx86w 220 88 81 84
wehu8 300 55 84 84

思路

1.根据题目意思,判断一个学生是否有资格获得整数的条件有2个:1.学生是否能编程>=200题 2.学生的总评成绩是否>=60
2.根据给的数据,可以建立4个
map<string,int> G_p,G_mid,G_final,G;
3.根据条件计算完G并且将满足条件的学生加进ans,并写个cmp排序
4.大坑 ! : **题目中的-1的意思表示的是没有学生的某一项没有分数(而非分数为0!没有分数代表没来考试,而分数为0代表考试考了0分!)**我自己是先把输入的0记为-2,这样map中默认为0的就表示没来考试的学生了。

代码:

#include<iostream>
#include<map>
#include<set>
#include<vector>
#include<algorithm>
using namespace std;
map<string,int> G_p,G_mid,G_final,G;
set<string> id;
struct node{
    string id;
    int p,mid,final,G;
};
vector<node> ans;
bool cmp(node a,node b){ return a.G!=b.G?a.G>b.G:a.id<b.id; }
int main(){
    int p,mid,final;
    cin>>p>>mid>>final;
    string a; int b;
    while(p--){
        cin>>a>>b;
        if(b==0) b=-2;
        G_p[a]=b;
        id.insert(a);
    }
    while(mid--){
        cin>>a>>b;
        if(b==0) b=-2;
        G_mid[a]=b;
        id.insert(a);
    }
    while(final--){
        cin>>a>>b;
        if(b==0) b=-2;
        G_final[a]=b;
        id.insert(a);
    }
    for(auto it=id.begin();it!=id.end();it++){
        if(G_mid[*it]>G_final[*it]) G[*it]=(int)(0.4*G_mid[*it]+0.6*G_final[*it]+0.5);
        else G[*it]=G_final[*it];
        if(G[*it]>=60&&G_p[*it]>=200)
        ans.push_back({*it,G_p[*it]==0?-1:G_p[*it],G_mid[*it]==0?-1:G_mid[*it],G_final[*it]==0?-1:G_final[*it],G[*it]});
    }
    sort(ans.begin(),ans.end(),cmp);
    for(int i=0;i<ans.size();i++)
    printf("%s %d %d %d %d\n",ans[i].id.c_str(),ans[i].p==-2?0:ans[i].p,ans[i].mid==-2?0:ans[i].mid,ans[i].final==-2?0:ans[i].final,ans[i].G);
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值