1118 Birds in Forest (25分) 测试点4错误的原因

1118 Birds in Forest (25分)

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤10
​4
​​ ) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B
​1
​​ B
​2
​​ … B
​K
​​

where K is the number of birds in this picture, and B
​i
​​ 's are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 10
​4
​​ .

After the pictures there is a positive number Q (≤10
​4
​​ ) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:
For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:
4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7
Sample Output:
2 10
Yes
No

这题我原来的思路是这样的:

  • 按照 拥有相同的鸟 合并 照片s:
  • 一只鸟 对应 多个照片 map<int,vector> getPicByIndex
  • Union同一只鸟对应的多个照片

后来做到后面发现测试点4没过。。发现要合并所有鸟才行,,因为第二小问问了任意2只鸟是否是一个团体的。

  • 改正:
  • 合并照片没问题,但是下面问2只鸟是否是一个团体的,所以要合并所有鸟
  • 通过每一张照片上的鸟都是一个团体的~

代码:

#include<iostream>
#include<algorithm>
#include<map>
#include<vector>
using namespace std;
/**
 * 按照 拥有相同的鸟 合并 照片s:
 * 一只鸟 对应 多个照片 map<int,vector<int>> getPicByIndex
 * Union同一只鸟对应的多个照片
 * 
 * 改正:
 * 合并照片没问题,但是下面问2只鸟是否是一个团体的,所以要合并所有鸟
 * 每一张照片上的鸟都是一个团体的~
 */
int n, father[10010],maxIndex=1;
int findFather(int x){
    int a = x;
    while(x!=father[x])
        x = father[x];
    while(a!=father[a]){
        int temp = a;
        a = father[a];
        father[temp] = x;
    }
    return x;
}
void Union(int a,int b){
    int Fa = findFather(a);
    int Fb = findFather(b);
    if(Fa!=Fb){
        father[Fa] = Fb;
    }
}
void init(){
    for (int i = 1; i < 10010;i++){
        father[i] = i;
    }
}
int main(){
    cin >> n;
    init();
    for (int i = 0; i < n;i++){
        int k, temp,temp2;
        cin >> k >> temp;
        maxIndex = max(maxIndex, temp);
        for(int i=1;i<k;i++){
            cin >> temp2;
            maxIndex = max(maxIndex, temp2);
            Union(temp, temp2);
        }
    }   
    int FatherNum[10010] = {0}, count = 0;
    for (int i = 1; i <= maxIndex;i++){
        FatherNum[findFather(i)]++;
    }
    for (int i = 1; i <= maxIndex;i++){
        if(FatherNum[i]>0){
            count++;
        }
    }
    printf("%d %d\n", count, maxIndex);
    int k;
    cin >> k;
    while(k--){
        int a, b;
        cin >> a >> b;
        printf("%s\n",findFather(a)==findFather(b)?"Yes":"No");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值