UVA 10020 Minimal coverage(最小覆盖问题)

 Minimal coverage 

 


The Problem

Given several segments of line (int the X axis) with coordinates [Li,Ri]. You are to choose the minimal amount of them, such they would completely cover the segment [0,M].

The Input

The first line is the number of test cases, followed by a blank line.

Each test case in the input should contains an integer M(1<=M<=5000), followed by pairs "Li Ri"(|Li|, |Ri|<=50000, i<=100000), each on a separate line. Each test case of input is terminated by pair "0 0".

Each test case will be separated by a single line.

The Output

For each test case, in the first line of output your programm should print the minimal number of line segments which can cover segment [0,M]. In the following lines, the coordinates of segments, sorted by their left end (Li), should be printed in the same format as in the input. Pair "0 0" should not be printed. If [0,M] can not be covered by given line segments, your programm should print "0"(without quotes).

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

1
-1 0
-5 -3
2 5
0 0

1
-1 0
0 1
0 0


Sample Output

0

1
0 1

题目大意,求能覆盖【0,M】的最小区间数,并且输出这些区间

 

代码:

#include<iostream>
#include<algorithm>
using namespace std;
struct node
{
	int start;       //创建区间
	int end1; 
}a[100005],v[100005];  //a数组作为输入区间的结构数组,v数组记录符合要求的区间
int cmp(node a,node b)    //按区间右值更新
{
	return a.end1>b.end1;
}
int t,start,end1,j,k;      //k记录符合要求的区间数
int main()
{
	scanf("%d",&t);
	while(t--)
	{   j=0;k=0;start=0;
		scanf("%d",&end1);
		while(~scanf("%d%d",&a[j].start,&a[j].end1)&&a[j].start+a[j].end1)
		{
			j++;
		}
		sort(a,a+j,cmp);
		while(start<end1)       
		{
			int i;
			for(i=0;i<j;i++)
			{
				if(a[i].start<=start&&a[i].end1>start)
				{
					start=a[i].end1;
					v[k++]=a[i];      //记录区间并计数
				    break;
				}
			}
			if(i==j)break;          //不符合要求
		}
		if(start<end1)printf("0\n");       
		else                              //输出区间数并将v数组记录的区间依次输出
		{
			printf("%d\n",k);
            for(int i=0;i<k;i++)
				printf("%d %d\n",v[i].start,v[i].end1);
		}
		if(t)printf("\n");               //每个实例换行
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值