Problem Descrption
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework).
Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.
Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.
Sample Input
2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3
Sample Output
2
Computer
Math
English
3
Computer
English
Math
Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the
word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.
#include<iostream>
#include<algorithm>
#include<cstring>
#define maxn 10005
#define INF 10000000
using namespace std;
struct node
{
string s;
int d,c;
}a[22];
struct dpp
{
int pre;//前一个状态
int now_time;//当前的时间
int cost;//当前扣除的最小分数
int p;//以那个点结尾扣除的分数最小
}dp[1<<16];
int main()
{
int t,n;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(int i=0; i<n; i++)
{
cin>>a[i].s;
scanf("%d%d",&a[i].d,&a[i].c);
}
dp[0].cost=dp[0].pre=dp[0].now_time=0;
for(int i=1;i<(1<<n);i++)
{
dp[i].cost=INF;
for(int j=n-1;j>=0;j--)
{
if(i&(1<<j))
{
int tmp;//当前将要扣除的分数
int now_pre;//当前的前一个状态
now_pre=i-(1<<j);
if(dp[now_pre].now_time+a[j].c>a[j].d)
{
tmp=dp[now_pre].now_time+a[j].c-a[j].d;
}
else
{
tmp=0;
}
if(dp[i].cost>(dp[now_pre].cost+tmp))
{
dp[i].cost=dp[now_pre].cost+tmp;
dp[i].now_time=dp[now_pre].now_time+a[j].c;
dp[i].pre=now_pre;
dp[i].p=j;
}
}
}
}
int now=(1<<n)-1;
printf("%d\n",dp[now].cost);
stack<int> s;
while(dp[now].now_time)
{
int p=dp[now].p;
s.push(p);
now=dp[now].pre;
}
while(!s.empty())
{
int p=s.top();
cout<<a[p].s<<endl;
s.pop();
}
}
return 0;
}