GZHU18级寒假训练:Leo's Trial H

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

#include <iostream>
#include <queue>
using namespace std;
int n[5][5];
int vis[5][5];
int i = 1;
struct Q
{
	int x, y;
	
}aq,bq,re[5][5];
queue<Q>aa;
int dir[4][2]={ {0,1},{0,-1},{1,0},{-1,0} };
void goback(int y,int x )
{
	if (x == 0 && y == 0)
	{
		printf_s("(%d, %d)\n", y, x);
		return;
	}
	else
	{
		goback(re[y][x].y, re[y][x].x);
		printf_s("(%d, %d)\n", y, x);
	}
}
void bfs(Q a)
{
	vis[a.y][a.x] = 1;
	aa.push(a);
	while (!aa.empty())
	{
		a = aa.front();
		vis[a.y][a.x] = 1;
		aa.pop();
		if (a.x == 4 && a.y == 4)
		{
			goback(4, 4);
			
		}
		else
		{
			for (int i = 0; i < 4; i++)
			{
				aq = a;
				aq.x =a.x+ dir[i][0];
				aq.y =a.y+ dir[i][1];
				if (aq.x >= 0 && aq.y >= 0 && aq.x <= 4 && aq.y <= 4 && vis[aq.y][aq.x] == 0 && n[aq.y][aq.x] == 0)
				{
					re[aq.y][aq.x].x = a.x;
					re[aq.y][aq.x].y = a.y;
					aa.push(aq);
				}
			}
		}
	}
	
}

int main()
{
		for (int i = 0; i < 5; i++)
			for (int j = 0; j < 5; j++)
				cin >> n[i][j];
		memset(vis, 0, sizeof(vis));
		aq.x = 0;
		aq.y = 0;
		bfs(aq);
		i = 1;
  
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值