GZHU18级寒假训练:Leo's Trial-E

HDU-2870

  • Now here is a matrix with letter ‘a’,‘b’,‘c’,‘w’,‘x’,‘y’,‘z’ and you can change ‘w’ to ‘a’ or ‘b’, change ‘x’ to ‘b’ or ‘c’, change ‘y’ to ‘a’ or ‘c’, and change ‘z’ to ‘a’, ‘b’ or ‘c’. After you changed it, what’s the largest submatrix with the same letters you can make?
  • Input
    The input contains multiple test cases. Each test case begins with m and n (1 ≤ m, n ≤ 1000) on line. Then come the elements of a matrix in row-major order on m lines each with n letters. The input ends once EOF is met.
  • Output
    For each test case, output one line containing the number of elements of the largest submatrix of all same letters.
  • Sample Input
    2 4
    abcw
    wxyz
  • Sample Output
    3

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
 
int a[1100][1100],b[1100][1100],c[1100][1100],l[1100],r[1100];
 
int main()
{
    int M,N;
    char ch;
    while(~scanf("%d%d",&M,&N))
    {
        for(int i = 1; i <= M; i++)
        {
            getchar();
            for(int j = 1; j <= N; j++)
            {
                scanf("%c",&ch);
                if(ch=='a' || ch=='w' || ch=='y' || ch=='z')
                    a[i][j] = a[i-1][j] + 1;
                else
                    a[i][j] = 0;
                if(ch=='b' || ch=='w' || ch=='x' || ch=='z')
                    b[i][j] = b[i-1][j] + 1;
                else
                    b[i][j] = 0;
                if(ch=='c' || ch=='x' || ch=='y' || ch=='z')
                    c[i][j] = c[i-1][j] + 1;
                else
                    c[i][j] = 0;
            }
        }
 
        int area = -0xffffff0;
        for(int i = 1; i <= M; i++)
        {
//            ------------------求a最大面积---------------
            l[0] = 1,r[N+1] = N;
            a[i][0] = a[i][N+1] = -1;
            for(int j = 1; j <= N; j++)
            {
                l[j] = j;
                while(a[i][l[j]-1] >= a[i][j])
                    l[j] = l[l[j]-1];
            }
            for(int j = N; j >= 1; j--)
            {
                r[j] = j;
                while(a[i][r[j]+1] >= a[i][j])
                    r[j] = r[r[j]+1];
            }
            for(int j = 1; j <= N; j++)
            {
                if(a[i][j] * (r[j]-l[j]+1) > area)
                    area = a[i][j] * (r[j]-l[j]+1);
            }
//            ----------------求b最大面积----------------
            l[0] = 1,r[N+1] = N;
            b[i][0] = b[i][N+1] = -1;
            for(int j = 1; j <= N; j++)
            {
                l[j] = j;
                while(b[i][l[j]-1] >= b[i][j])
                    l[j] = l[l[j]-1];
            }
            for(int j = N; j >= 1; j--)
            {
                r[j] = j;
                while(b[i][r[j]+1] >= b[i][j])
                    r[j] = r[r[j]+1];
            }
            for(int j = 1; j <= N; j++)
            {
                if(b[i][j] * (r[j]-l[j]+1) > area)
                    area = b[i][j] * (r[j]-l[j]+1);
            }
//            -------------求c最大面积---------------
            l[0] = 1,r[N+1] = N;
            c[i][0] = c[i][N+1] = -1;
            for(int j = 1; j <= N; j++)
            {
                l[j] = j;
                while(c[i][l[j]-1] >= c[i][j])
                    l[j] = l[l[j]-1];
            }
            for(int j = N; j >= 1; j--)
            {
                r[j] = j;
                while(c[i][r[j]+1] >= c[i][j])
                    r[j] = r[r[j]+1];
            }
            for(int j = 1; j <= N; j++)
            {
                if(c[i][j] * (r[j]-l[j]+1) > area)
                    area = c[i][j] * (r[j]-l[j]+1);
            }
        }
        printf("%d\n",area);
    }
    return 0;
}

代码来源:https://blog.csdn.net/lianai911/article/details/40787757

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值