1007 Maximum Subsequence Sum (25分)

1007 Maximum Subsequence Sum 25分

原题

Given a sequence of K integers { N1, N2, …, NK }. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.
Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

题意

输入一个长度为n的序列
求出里面的和最大的子序列
如样例的1 2 3 4和3 7就是和最大子序列
输出第一个数是和最大子序列的和,第二三个数是和最大子序列的首尾元素,看英语很容易误解成首尾indice。。。
注意,如果输入序列全为负数,那么和最大序列的和定义为0,并且输出序列首尾元素


思路

一眼看过去就很像经典的最大子区间和问题,写了一遍后发现只对了一个点,后来检查发现如果序列除了一个元素为0外全为负数,那么应该输出0 0 0,所以在前面基础上还要加上0 0 0的特判。

代码

#include<iostream>
using namespace std;
#define ll long long
#define N 10010
int a[N];
signed main(){
	int n,sum=0,tl=0,l=0,r=-1,ans=0;
	bool f=0;
	cin>>n;
	for(int i=0;i<n;i++){
		cin>>a[i];
		sum+=a[i];
		if(sum<0){
			tl=i+1;
			sum=0;
		}
		if(sum>ans){
			f=1;
			r=i;
			l=tl;
			ans=sum;
		}
		if(sum==0&&ans==0&&a[i]==0){
			l=r=i;
			f=1;
		}
	}
	if(f)
	cout<<ans<<" "<<a[l]<<" "<<a[r]<<endl;
	else {
		cout<<"0 "<<a[0]<<" "<<a[n-1]<<endl;
	}
	return 0;
} 

思路改进

算法其实没有什么可以改进的,就是处理边界问题比较麻烦

这里给出几组数据
输入

5
-1 -1 0 -1 -1

输出

0 0 0

输入

5
-2 -1 -7 -1 -9

输出

0 -2 -9

输入

5
99 1 0 -1 100

输出

199 99 100
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值