1096 Consecutive Factors (20 point(s)) PAT甲级

1096 Consecutive Factors (20 point(s))

数字处理

题目

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2^31).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

思路

题意

给定数组n(1<n<2^31),求出n中最大的k个可以被n整除的连续整数。

分析

直接从小到大遍历每个可能的连续整数乘积,用base记录开始的数字,如果连续的数目大于之前找到的就更新maxf。最后如过maxf为0则代表数字n是质数,maxf为1,因为连续的因数不能为1所以为n本身。

注意要用sqrt(n)+1来限制base和连续相乘的数的大小(最大分解情况是连续两个sqrt(n)附近的数相乘),否则会超时。

代码

#include <iostream>
#include <cmath>
using namespace std;

int main()
{
    int n, maxf = 0, base = 2, ansb = 2;
    scanf("%d", &n);
    int maxn = sqrt(n)+1;
    while(base <= maxn){
        int i, div = 1;
        for(i = base; i <= maxn; i++){//这里也要限制,不然最后一个点会超时
            div *= i;
            if(n%div != 0) break;
        }
        if(i-base > maxf ){
            maxf = i-base;
            ansb = base;
        }
        base++;
    }
    if(maxf == 0){
        printf("%d\n%d\n", 1, n);
    }else{
        printf("%d\n", maxf);
        for(int i = ansb; i-ansb < maxf ;i++)
            printf("%d%s", i, (i-ansb+1) == maxf ? "\n" : "*");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值