1160 Forever (20 point(s))

本文介绍了解决一个编程问题的方法,即寻找具有特定数字属性的Forever数字,这些数字的位数为K,其所有位之和满足m和m+1的和的公约数为大于2的素数。博主通过搜索策略和素数、最大公约数判断,展示了如何找到并输出这些数字对(n, A)的解决方案。
摘要由CSDN通过智能技术生成

1160 Forever (20 point(s))

题目

“Forever number” is a positive integer A with K digits, satisfying the following constrains:

the sum of all the digits of A is m;
the sum of all the digits of A+1 is n; and
the greatest common divisor of m and n is a prime number which is greater than 2.
Now you are supposed to find these forever numbers.

Input Specification:
Each input file contains one test case. For each test case, the first line contains a positive integer N ( ≤ 5 ) N (≤5) N(5). Then N lines follow, each gives a pair of K ( 3 < K < 10 ) K (3<K<10) K(3<K<10) and m ( 1 < m < 90 ) m (1<m<90) m(1<m<90), of which the meanings are given in the problem description.

Output Specification:
For each pair of K and m, first print in a line Case X, where X is the case index (starts from 1). Then print n and A in the following line. The numbers must be separated by a space. If the solution is not unique, output in the ascending order of n. If still not unique, output in the ascending order of A. If there is no solution, output No Solution.

Sample Input:

2
6 45
7 80

Sample Output:

Case 1
10 189999
10 279999
10 369999
10 459999
10 549999
10 639999
10 729999
10 819999
10 909999
Case 2
No Solution

思路

题意

给出N个测试样例,每个样例由两个数字K,m组成,判断是否能组成符合条件的数字K位数A。条件为:

  1. A的所有位数相加为m
  2. A+1的所有位数相加为n
  3. m和n的最大公约数为大于2的素数

输出符合以上条件的数字n和A,按照n从小到大排序,如果n相等则按照A从小到大排序。

思路

考察剪枝、素数判断和最大公约数判断。解题最关键的一点是分析题意得出只有尾数为9的数字满足题意,所以以十位为单位从小到大爆搜K位数判断是否符合条件即可。

解法

#include<bits/stdc++.h>
using namespace std;

int N, K, m;
vector<vector<int>> ans;

bool IsPrime(int num) {
	if (num <= 2) return false;
	for (int i = 2; i * i <= num; i++) {
		if (num % i == 0) return false;
	}
	return true;
}

int gcd(int a, int b) {
	return b ? gcd(b, a % b) : a;
}

int Sum(int num) {
	int sum = 0;
	while (num > 0) {
		sum += num % 10;
		num /= 10;
	}
	return sum;
}

bool Solution() {
	ans.clear();
	ans.resize(100);
	int cnt = 0;
	if (K * 9 < m) return false;//剪枝
	int start = pow(10, K - 1);
	for (int i = start + 9; i < start * 10; i += 10) {
		if (Sum(i) == m) {
			int n = Sum(i + 1);
			if (IsPrime(gcd(m, n))) {
				ans[n].push_back(i);
				cnt++;
			}
		}
	}
	return (cnt > 0);
}

int main() {
	scanf("%d", &N);
	for (int i = 1; i <= N; i++) {
		scanf("%d%d", &K, &m);
		printf("Case %d\n", i);
		if (Solution()) {
			for (int j = 0; j < ans.size(); j++)
				if(ans[j].size() != 0)
					for(int k = 0; k < ans[j].size(); k++)
						printf("%d %d\n", j, ans[j][k]);
		}
		else
			printf("No Solution\n");
	}

	return 0;
}

注意

  • IsPrime()内部判断是还是从2开始判断prime,不可以从3开始…
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值