1118 Birds in Forest (25 point(s)) PAT(并查集)

1118 Birds in Forest (25 point(s))

并查集

题目

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤104) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B1 B2 … B**K

where K is the number of birds in this picture, and B**i’s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.

After the pictures there is a positive number Q (≤104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No

思路

题意

给出N组数,每组数有k个数组成,这k个值代表鸟的index,k个鸟在同一棵树上(鸟的index是连续的从1到max_的值,max_ < = 1 0 4 <=10^4 <=104。查询q组数据,每组数据给出两个鸟的index,判断两鸟是否在同一棵树上。要求第一行输出树的数目和鸟的数目,再每行输出查询的结果。

分析

用并查集解决问题。根据题意,鸟的数目即给出的鸟的index中的最大值,树的数目遍历一遍所有鸟的father,求出树根树即树的数目。

解法

#include<iostream>
using namespace std;

int n, k, q, bird1, bird2;
int father[10005];
int max_ = 0, cnt = 0;

int findF(int v) {
	return v == father[v] ? v : findF(father[v]);
}

void Union(int a, int b) {
	int faA = findF(a);
	int faB = findF(b);
	if (faA < faB)
		father[faB] = faA;
	else
		father[faA] = faB;
}

int main() {
	scanf("%d", &n);
	for (int i = 0; i < 10005; i++)
		father[i] = i;
	for (int i = 0; i < n; i++) {
		scanf("%d%d", &k, &bird1);
		if (bird1 > max_) max_ = bird1;
		for (int j = 1; j < k; j++) {
			scanf("%d", &bird2);
			Union(bird1, bird2);
			if (bird2 > max_) max_ = bird2;
		}
	}
	for (int i = 1; i <= max_; i++) {
		if (findF(i) == i) cnt++;
	}
	printf("%d %d\n", cnt, max_);
	scanf("%d", &q);
	for (int i = 0; i < q; i++) {
		scanf("%d%d", &bird1, &bird2);
		if (findF(bird1) == findF(bird2)) printf("Yes\n");
		else printf("No\n");
	}
	return 0;
}

注意

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值