1118 Birds in Forest (25 point(s))

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤10​4​​) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B​1​​ B​2​​ ... B​K​​

where K is the number of birds in this picture, and B​i​​'s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 10​4​​.

After the pictures there is a positive number Q (≤10​4​​) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No

题目大意:一副画里面的鸟为同一棵树上的,问有多少颗树和多少只鸟,还有判断两只鸟是否在同一颗树上~

并查集模板传送门1107 Social Clusters (30 point(s)) 

分析:
将一副画中鸟使用Union函数合并在一起,root【i】保存 i 根的集合里面鸟的个数,vis用于标记鸟的id是否出现过。遍历root不为零的个数就是树的个数,累加值不为零的root【i】就是鸟的个数。判断两只鸟是否在一棵树上,只需看其find( )返回值是否相同即可。

PS:题目一看就知道是并查集做法,刷刷两下模板就写出来了,但谁跟谁合并啊,傻眼了,折腾了半天!!!说明理解和动手操作还是有很大的距离。

完整代码:

#include<bits/stdc++.h>
using namespace std;
const int N=10010;
int father[N],root[N],vis[N];
int find(int x){
	int z=x;
	while(x!=father[x]){
		x=father[x];
	} // 路径压缩,不写也可以AC 
	while(z!=father[z]){
		int a=z;
		father[a]=x;//挂到父节点 
		z=father[z];//回溯
	}
	return x; 
}

void Union(int a,int b){
	int fa=find(a);
	int fb=find(b);
	if(fa!=fb) father[fa]=fb;
}

int main(){
	int n,k,query,id,temp;
	cin>>n;
	//初始化 
	for(int i=1;i<=N;i++){
		father[i]=i;
	}
	for(int i=1;i<=n;i++){
		cin>>k>>id;
		vis[id]=true;//每个图片中的第一个先根鸟自成一个集合 
		for(int j=0;j<k-1;j++){
			cin>>temp;
			Union(id,temp);// 将 其他鸟temp与鸟id所在集合进行合并 
			vis[temp]=true; 
		} //这个for循环后形成以id为根的鸟集合
	}
	for(int i=1;i<=N;i++){
		if(vis[i]){
			int index=find(i);
			root[index]++;
		}
	}
	int cnt1=0,cnt2=0;
	for(int i=1;i<=N;i++){
		if(root[i]){
			cnt1++;//并查集集合个数
			cnt2+=root[i]; 
		}
	}
	cout<<cnt1<<" "<<cnt2<<endl;
	cin>>query;
	for(int i=0;i<query;i++){
		int a,b;
		cin>>a>>b;
		if(find(a)!=find(b))
		    cout<<"No\n";
		else cout<<"Yes\n";
	}
	return 0;
} 

That’s all !

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZCAIHUI_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值