poj1426(第一天题I)

题目:
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111

解:要求找出由1和0组成的数,可以用BFS方法搜索

第一位数只能是1 (01这就不是一个数了)
然后是10 11
相当于是二进制1<<1然后再加1或者0
1:1 2:10 3:11
即10=(2/2)*10+0 11=(2/2)*10+1
除以二可以找到未加0前的那截数,乘以10+0或者1就可以

代码:

#include<iostream>
using namespace std;
int tk[500000];
int main()
{
	int n;
	while (cin >> n)
	{
		if (n == 0)
		{
			break;
		}
		memset(tk, 0, sizeof(tk));
		tk[1] = 1;
		int i = 2;
		while (1)
		{
			tk[i] = (tk[i / 2] * 10 + i % 2);
			if (tk[i] % n == 0)
			{
				break;
			}
			i++;
		}
		cout << tk[i] << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值