POJ1426(DFS)

Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111

题意:给你一个n,让你算出一个每一位数都是1或0的n的倍数。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <queue>
#include <cmath>
#include <vector>

using namespace std;
bool ok;

void DFS(int a,unsigned long long b, int k)
{
    if (ok) {
        return;
    }
    if (b % a == 0) {
        ok = 1;
        cout << b << endl;
        return;
    }
    if (k == 19) return;//到了19层就回溯回去,走另一条路
    DFS (a, b * 10, k + 1);//b有两种方式可以获取,一个是b*10,一个是b*10+1
    DFS (a, b * 10 + 1, k + 1);
}

int main()
{
    int n;
    while (scanf ("%d", &n) != EOF) {
            if (n == 0) break;//别忘了终止条件
            ok = false;
            DFS (n, 1, 0);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值