H - 请使用sort(HDU 1031)

Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people’s opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.

Input

The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person’s satisfaction on the j-th element.

Output

For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.

Sample Input
3 6 4
2 2.5 5 1 3 4
5 1 3.5 2 2 2
1 1 1 1 1 10
3 3 2
1 2 3
2 3 1
3 1 2
Sample Output
6 5 3 1
2 1
题解

题意:

  • 有n个人对m个设计元素进行评价(浮点型)(一行是某个人对所有元素的评价),输出评价最高的前k个,按下标降序输出。

思路:

  • 将m个元素的评价和下标存入结构体数组里,先对所有元素进行按评价降序排列,再对评价排名前K的元素进行按下标降序排列,按顺序输出前k个元素的下标。
Code
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<string>
#include<memory.h>

using namespace std;

struct node
{
    double sum;//总评价
    int num;//index(下标)
}a[1005];

bool cmp1(node x, node y)
{
    return x.sum > y.sum;//按评价降序排列
}

bool cmp2(node x, node y)
{
    return x.num > y.num;//按下标降序排列
}

int main()
{  
    int n, m, k;
    double tem;
    while(cin >> n >> m >> k)
    {
        memset(a, 0, sizeof(a));//输入每组测试数据前都初始化

        for (int i = 0; i < n; i++)
            for (int j = 0; j < m; j++)
            {
                cin >> tem;
                a[j].sum += tem;//累加对第j+1个设计元素的评价
                a[j].num = j + 1;//记录下标,因为在排序时在数组中的位置
                				//有可能不是这个设计元素的下标
            }
        sort(a, a + m, cmp1);//对所有元素进行按评价降序排列
        sort(a, a + k, cmp2);//对评价排名前K的元素进行按下标降序排列
        for(int i = 0; i < k - 1 ; i++)
            cout << a[i].num << ' ';
        cout << a[k - 1].num << endl;
    }  
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值