U - Long Distance Racing(POJ 3672)

Description

Bessie is training for her next race by running on a path that includes hills so that she will be prepared for any terrain. She has planned a straight path and wants to run as far as she can – but she must be back to the farm within M seconds (1 ≤ M ≤ 10,000,000).

The entire path she has chosen is T units (1 ≤ T ≤ 100,000) in length and consists of equal-length portions that are uphill, flat, or downhill. The input data describes path segment i with a single character Si that is u, f, or d, indicating respectively uphill, flat, or downhill.

Bessie takes U seconds (1 ≤ U ≤ 100) to run one unit of uphill path, F (1 ≤ F ≤ 100) seconds for a unit of flat path, and D (1 ≤ D ≤ 100) seconds for a unit of downhill path. Note that, when returning home, uphill paths become downhill paths and downhill paths become uphill paths.

Find the farthest distance Bessie can get from the farm and still make it back in time.

Input

Line 1: Five space-separated integers: M, T, U, F, and D
Lines 2…T+1: Line i+1 describes path segment i with a single letter: Si

Output

Line 1: A single integer that is the farthest distance (number of units) that Bessie can get from the farm and make it back in time.

Sample Input
13 5 3 2 1
u
f
u
d
f
Sample Output
3
题解

题意:

  • 给定m时间, t段路,每一段路可能是平路、上坡或者下坡(返回时相反),跑完一段路相应的用时为F,U,D,问在时间m内,跑一个来回,多长跑多远

思路:

  • 既然是一个来回,那么有一次上坡就会对应一次下坡。所以,对于某一段路来说,平路花费时间为2*F,非平路为U+D。
  • 遍历这 t段路,假设在当前位置返回,计算来回时间,若不超过时间m,则记下当前位置,直到遍历完,得出最远距离
Code
#include<iostream>
using namespace std;

int main()
{
    int m, t, U, F, D, i, len = 0, Time;
    cin>>m>>t>>U>>F>>D;
    char ch;
    Time = 0;
    for(i = 1 ; i <= t; i++)
    {   
        cin>>ch;
        if(ch == 'f')
            Time += 2 * F;
        else if(ch == 'u' || ch == 'd')    
            Time += D + U;     
        if(Time < m)
            len = i;   
    }
    cout<<len<<endl;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值