hdu-1754 I Hate It(超时解决办法为使用g++编译器)

Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。

Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取’Q’或’U’) ,和两个正整数A,B。
当C为’Q’的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为’U’的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。

Output
对于每一次询问操作,在一行里面输出最高成绩。

Sample Input
5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5

Sample Output
5
6
5
9

要ac要用g++编译器

#include <iostream>
#include <algorithm>
using namespace std;
const int MAXNODE = 1 << 19;
const int MAX = 2e6 + 10;
//int max(int a, int b) {
//	if (a > b)return a;
//	else return b;
//}
struct NODE {
	int value;
	int left, right;
};
NODE node[MAXNODE];
int father[MAX];

void BuildTree(int i,int left,int right) {
	node[i].left = left;
	node[i].right = right;
	node[i].value = 0;
	if (left == right) {
		father[left] = i;
		return;
	}
	BuildTree(i <<1, left,(int)(floor (left + right) / 2.0));
	BuildTree((i << 1) + 1, (int)(floor(left + right) / 2.0)+1, right);
}

void UpdateTree(int ri) {
	if (ri == 1)return; 
	int fi = ri / 2;
	int a = node[fi << 1].value;
	int b = node[(fi << 1) + 1].value;
	node[fi].value = max(a, b);
	UpdateTree(ri / 2);
}

int Max;
void Query(int i, int l, int r) {
	if (node[i].left == l && node[i].right == r) {
		Max = max(Max, node[i].value);
		return;
	}
	i = i << 1;
	if (l <= node[i].right) {
		if (r <= node[i].right) Query(i, l, r);
		else Query(i, l, node[i].right);
	}
	i++;
	if (r >= node[i].left) {
		if (l >= node[i].left)Query(i, l, r);
		else Query(i, node[i].left, r);
	}
}


int  main() {

	int n, m, g;
	ios::sync_with_stdio(false);
	while (cin >> n >> m) {
		
		BuildTree(1, 1, n);
		for (int i = 1; i <= n; i++) {
			cin >> g;
			node[father[i]].value = g;
			UpdateTree(father[i]);
		}
		char op;
		int a, b;
		while (m--) {
		
			cin>>op>> a >> b;
			if (op == 'Q') {
				Max = 0;
				Query(1, a, b);
				cout << Max << endl;
		
			}
			else {
				node[father[a]].value = b;
				UpdateTree(father[a]);
			}
		}
	}
	return 1;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值