HDU - 1058 Humble Numbers (DP+丑数打表)

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, … shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line saying “The nth humble number is number.”. Depending on the value of n, the correct suffix “st”, “nd”, “rd”, or “th” for the ordinal number nth has to be used like it is shown in the sample output.
Sample Input
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0
Sample Output
The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.
问题链接http://acm.hdu.edu.cn/showproblem.php?pid=1058
问题简述:要求出一个数列:里面每个数的因子只有2,3,5,7(丑数),输入n,输出第n个丑数
问题分析:题目要求n在5842以内,第一想法就是写一个程序把丑数打表出来,再把5842以内的丑数放在一个数组里直接输出。发现不需要打表时间也是够的。(求丑数用DP,后一个丑数是本身乘与2,3,5,7之中最小的一个,由此列出状态方程,每进一个数把他乘与的数的因子次数+1,,但是最重要的是卡输出,11,112,113,1113,111,1111,5111…全部都是th!由于这个原因我卡了两个小时…
AC通过的C++语言程序如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include <algorithm>
#include<string.h>
#include<stdio.h>
using namespace std;
int chou[5845];
int main()
{
	int n = 1;
	int a, b, c, d;
	a = b = c = d = 1;
	chou[1] = 1;
	while (n < 5844) 
	{
		n++;
		chou[n] = min(min(2 * chou[a], 3 * chou[b]), min(5 * chou[c], 7 * chou[d]));
		if (chou[n] == 2 * chou[a]) { a++; }
		if (chou[n] == 3 * chou[b]) { b++; }
		if (chou[n] == 5 * chou[c]) { c++; }
		if (chou[n] == 7 * chou[d]) { d++; }
	}
	int i;
	while (cin >> i)
	{
		if (i == 0) { return 0; }
		cout << "The ";
		if (i % 10 == 1 && i % 100 != 11) { cout << i << "st"; }
		else if (i % 10 == 2 && i % 100 != 12) { cout << i << "nd"; }
		else if (i % 10 == 3 && i % 100 != 13) { cout << i << "rd"; }
		else cout << i << "th";
		cout << " humble number is " << chou[i] << ".";
		cout << endl;
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值