数据结构实验之图论八:欧拉回路
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
在哥尼斯堡的一个公园里,有七座桥将普雷格尔河中两个岛及岛与河岸连接起来。
能否走过这样的七座桥,并且每桥只走一次?瑞士数学家欧拉最终解决了这个问题并由此创立了拓扑学。欧拉通过对七桥问题的研究,不仅圆满地回答了哥尼斯堡七桥问题,并证明了更为广泛的有关一笔画的三条结论,人们通常称之为欧拉定理。对于一个连通图,通常把从某结点出发一笔画成所经过的路线叫做欧拉路。人们又通常把一笔画成回到出发点的欧拉路叫做欧拉回路。具有欧拉回路的图叫做欧拉图。
你的任务是:对于给定的一组无向图数据,判断其是否成其为欧拉图?
Input
连续T组数据输入,每组数据第一行给出两个正整数,分别表示结点数目N(1 < N <= 1000)和边数M;随后M行对应M条边,每行给出两个正整数,分别表示该边连通的两个结点的编号,结点从1~N编号。
Output
若为欧拉图输出1,否则输出0。
Sample Input
1 6 10 1 2 2 3 3 1 4 5 5 6 6 4 1 4 1 6 3 4 3 6
Sample Output
1
Hint
如果无向图连通并且所有结点的度都是偶数,则存在欧拉回路,否则不存在。
Source
xam
// 数据结构实验之图论八:欧拉回路
// 并查集实现
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <deque>
#include <iostream>
#include <list>
#include <map>
#include <queue>
#include <set>
#include <stack>
#include <vector>
using namespace std;
int gra[1005][1005];
int f[1005]; // 记录祖先
int p[1005]; // 记录每个点的度
int find_root(int i) {
if (f[i] == i)
return i;
else {
f[i] = find_root(f[i]);
return f[i];
}
}
void union_set(int u, int v) {
int t1 = find_root(u);
int t2 = find_root(v);
if (t1 != t2) f[t2] = t1;
}
int main() {
int n, m, t, u, v;
cin >> t;
while (t--) {
cin >> n >> m;
memset(gra, 0, sizeof(gra));
memset(p, 0, sizeof(p));
for (int i = 1; i <= n; i++) f[i] = i;
for (int i = 0; i < m; i++) {
cin >> u >> v;
union_set(f[u], f[v]);
p[u]++;
p[v]++;
}
int flag = 1, cnt = 0;
for (int i = 1; i <= n; i++) {
if (f[i] == i) {
cnt++;
}
// 无向欧拉图每个点 都是偶数度
if (p[i] % 2) {
flag = 0;
break;
}
}
if (cnt != 1 || !flag)
printf("0\n");
else
printf("1\n");
}
}