OJ书本分发

1 篇文章 0 订阅

题目

Description

You are given N number of books. Every ith book has Pi number of pages. You have to allocate books to M number of students. There can be many ways or permutations to do so. In each permutation one of the M students will be allocated the maximum number of pages. Out of all these permutations, the task is to find that particular permutation in which the maximum number of pages allocated to a student is minimum of those in all the other permutations, and print this minimum value. Each book will be allocated to exactly one student. Each student has to be allocated at least one book.每一个学生只能分配连续出现的书本。

Input

The first line contains ‘T’ denoting the number of testcases. Then follows description of T testcases:Each case begins with a single positive integer N denoting the number of books.The second line contains N space separated positive integers denoting the pages of each book.And the third line contains another integer M, denoting the number of studentsConstraints:1<= T <=70,1<= N <=50,1<= A [ i ] <=250,1<= M <=50,Note: Return -1 if a valid assignment is not possible, and allotment should be in contiguous order (see explanation for better understanding)

Output

For each test case, output a single line containing minimum number of pages each student has to read for corresponding test case.

Sample Input 1

1
4
12 34 67 90
2

Sample Output 1

113
思路
  • 把学生看成桶,问题就变成怎么把书分到桶里,保证每个桶里都得有书,并且这些桶中装的最多的那个桶是所有分配方案里最小的
  • 我们可以枚举桶的大小,来模拟分配
  • 其中桶的大小最大不会超过所有书的容量之和,但至少和最厚的那本书一样
  • 这样,我们就可以用二分法来枚举,枚举操作的复杂度从O(N) 变成 O(LogN)
  • 总的复杂度O(NlogN)
#include <iostream>
#include <vector>


using namespace std;


int get_bucket_cnt(vector<int>&pages,int bkSize){
    int currentBkSize = 0; //当前桶的大小
    int bucketCnt = 1;
    for(auto&e:pages){
        currentBkSize+=e;
        if(currentBkSize > bkSize)
        {
            bucketCnt++;
            currentBkSize = e;
        }
    }
    return bucketCnt;
}


int solution(vector<int>&pages,int stuCnt){
    if(stuCnt>pages.size())return -1;
    int l = pages[0],r=0;
    for(auto&e:pages){
        l = max(l,e);
        r+=e;
    }

    while (l<r){
        int mid = l+(r-l)/2;
        int bkCnt = get_bucket_cnt(pages,mid);
        if(bkCnt<=stuCnt){
            r =mid;
        }else l = mid+1;
    }
    return l;
}


void processCase()
{
    int n;
    cin>>n;
    vector<int> arr(n);
    for (int i = 0; i <n ; ++i) {
        cin>>arr[i];
    }
    int m;cin>>m;
    cout<<solution(arr,m)<<endl;
}

int main(){
    int caseNum;
    cin>>caseNum;
    while(caseNum-->0){
        processCase();
    }
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值