16.书本分发

Description
You are given N number of books. Every ith book has Pi number of pages. You have to allocate books to M number of students. There can be many ways or permutations to do so. In each permutation one of the M students will be allocated the maximum number of pages. Out of all these permutations, the task is to find that particular permutation in which the maximum number of pages allocated to a student is minimum of those in all the other permutations, and print this minimum value. Each book will be allocated to exactly one student. Each student has to be allocated atleast one book.

Input
The first line contains ‘T’ denoting the number of testcases. Then follows description of T testcases:Each case begins with a single positive integer N denoting the number of books.The second line contains N space separated positive integers denoting the pages of each book.And the third line contains another integer M, denoting the number of studentsConstraints:1<= T <=70,1<= N <=50,1<= A [ i ] <=250,1<= M <=50,Note: Return -1 if a valid assignment is not possible, and allotment should be in contiguous order (see explanation for better understanding)

Output
For each test case, output a single line containing minimum number of pages each student has to read for corresponding test case.

Sample Input 1
1
4
12 34 67 90
2

Sample Output 1
113

# 分桶问题,同漆狗屋问题
# 将l数组中的书本分给一些同学,每个人最多看mid_cap页,能分给多少人
def average(l, mid_cap):
    res = 1
    sum = 0
    for i in l:
        sum += i
        if sum > mid_cap:
            res += 1
            sum = i
    return res


# 书本数组、人数、最小桶、最小桶
def solution(l, p, min_cap, max_cap):
    if min_cap == max_cap:
        return min_cap
    else:
        # 二分法
        mid_cap = (min_cap + max_cap) // 2
        n_s = average(l, mid_cap)
        # 桶比较大,分的人少了,可以将桶变小点
        if n_s <= p:
            return solution(l, p, min_cap, mid_cap)
        else:
            return solution(l, p, mid_cap + 1, max_cap)


if __name__ == '__main__':
    n = int(input())
    for i in range(n):
        number = int(input())
        l = list(map(int, input().strip().split()))
        p = int(input())
        min_cap = max(l)
        max_cap = sum(l)
        result = solution(l, p, min_cap, max_cap)
        print(result)
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值