PAT 甲级1093 C++题解

1093 Count PAT’s (25 分)

Question:
The string APPAPT contains two PAT’s as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters. Now given any string, you are supposed to tell the number of PAT’s contained in the string.

Input Specification:
Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5​​ characters containing only P, A, or T.

Output Specification:
For each test case, print in one line the number of PAT’s contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:
APPAPT
Sample Output:
2

解题思路

如果用暴力解法遍历会导致在字符串过长的情况下时间复杂度陡增,因此此题需要考虑更加巧妙的方法。通过读题可以发现对于任意A,其能构成的PAT的数量应与左侧P和右侧T进行排列组合,也就是说假设左侧n个P,右侧有m个T,则能够构成m*n个PAT,如此一来此题便迎刃而解。

需要注意的是string这个标准模板库如果要输入或输出整个字符串,则只能用cin和cout

# include <iostream>
# include <string>
using namespace std;

int main()
{
    string str;
    int sum,count[2] = {0};//count[0]记录左侧P的个数,count[1]记录右侧T的个数
    cin>>str;
    for(string::iterator it = str.begin(); it!=str.end();it++)//由于右侧T要递减,因此先遍历一轮记录有多少个T
    {
        if(*it == 'T')
            count[1]++;
    }
    for(string::iterator it = str.begin(); it!=str.end();it++)//逢A计算count[0]*count[1]并累加至sum中
    {
        if(*it == 'P')
            count[0]++;
        else if(*it == 'T')
            count[1]--;
        else
            sum += (count[0]*count[1])%1000000007;
        sum = sum%1000000007;
    }
    printf("%d",sum);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值