1093. Count PAT's (25)

389 篇文章 1 订阅
140 篇文章 0 订阅

1093. Count PAT’s (25)
时间限制 120 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 CAO, Peng

The string APPAPT contains two PAT’s as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.
Now given any string, you are supposed to tell the number of PAT’s contained in the string.
Input Specification:
Each input file contains one test case. For each case, there is only one line giving a string of no more than 105 characters containing only P, A, or T.
Output Specification:
For each test case, print in one line the number of PAT’s contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.
Sample Input:
APPAPT
Sample Output:
2

思路一:对于每一个A,可以组成pat的为A左边的P的个数与A右边T的个数,所以统计所有的A能组成的个数对1000000007求余即可

#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <cstring>
#include <fstream>
#include <string>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
using namespace std;

const int MaxN = 100010;

int main()
{
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
    //fstream cin("data.txt");
#endif // _DEBUG

    char str[MaxN];
    int ALeftP[MaxN] = { 0 };
    long long res = 0;
    int countT = 0;

    scanf("%s", str);
    ALeftP[0] = (str[0] == 'P');

    for (int i = 1; str[i]; ++i)
    {
        if (str[i] == 'P')
            ALeftP[i] = ALeftP[i - 1] + 1;
        else
            ALeftP[i] = ALeftP[i - 1];
    }

    for (int i = strlen(str) - 1; i >= 0; --i)
    {
        if (str[i] == 'T') ++countT;
        else if (str[i] == 'A')
            res =  (res + ALeftP[i] * countT) % 1000000007;
    }

    printf("%lld", res);

#ifdef _DEBUG
    //cin.close();
#ifndef _CODEBLOCKS
    std::system("pause");
#endif // !_CODEBLOCKS
#endif // _DEBUG

    return 0;
}
#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <fstream>
#include <string>
#include <cmath>
#include <algorithm>
#include <queue>
using namespace std;

int main()
{
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
    //fstream cin("data.txt");
#endif // _DEBUG

    const int MaxN = 100010;
    char str[MaxN];
    int P = 0, A = 0, T = 0;
    unsigned long long C = 0, Mod = 1000000007, CP = 0,CA = 0, CT = 0;;
    scanf("%s", str);
    for (; str[T]; ++T)
    {
        while (str[T] != 'T' && str[T])++T;//找到尚未利用的T;
        if (!(str[T] == 'T'))
            break;
        for(;A < T && str[T];++A)
        {

            while (A < T && str[A] != 'A')++A;//掠过不是A的字符
            if (!(str[A] == 'A'))
                break;
            for (;P < A;++P)
            {
                if (str[P] == 'P')
                    ++CP; // 当前字母是P,可以组成PAT,P的数量加1
            }
            CA = CP % Mod;//此处为当前所指的A左边有多少个P,即有CP总组成方式
            CT += CA;//当前T有所有A的组成方法之和总组成方式
        }
        CT %= Mod;
        C = (CT + C) % Mod;//当前T加上之前的组成方法即为总的组成方式
    }

    printf("%lld", C);


#ifdef _DEBUG
    //cin.close();
#ifndef _CODEBLOCKS
    system("pause");
#endif // !_CODEBLOCKS
#endif // _DEBUG

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值