PAT甲级 A1040

PAT甲级 A1040

题目详情

1040 Longest Symmetric String (25分)
Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:
Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:
For each test case, simply print the maximum length in a line.

Sample Input:
Is PAT&TAP symmetric?
Sample Output:
11

解题思路

这道题需要求一个字符串中的最长回文串。题目中如果采用暴力搜索,时间和空间都会产生问题。因此我们可以采用动态规划进行解题,我们每次设置一个二维数组记录其区间是否为回文数,每次遍历时从小到大,对单字符,相邻字符先进行更新,而后自底向上,每次获得更大的区间是就更新区间长度
AC代码如下

#include<iostream>
#include<string>
#include<vector>
#include<cmath>
#include<string>
#include<algorithm>
#include<iomanip>
#include<map>
int dp[1000][1000] = { 0 };
using namespace std;
int main() {
	for (int i = 0; i < 1000; i++) {
		dp[i][i] = 1;
	}
	string s;
	getline(cin, s);
	int max = 0;
	for (int i = 0; i < s.size(); i++) {
		for (int j = i - 1; j >= 0; j--) {
			if (j == i - 1) {
				if (s[i] == s[j]) {
					dp[i][j] = 1;
					if (i - j + 1 > max) {
						max = i - j + 1;
					}
				}
			}
			else {
				if (s[i] == s[j] && dp[i - 1][j + 1] == 1) {
					dp[i][j] = 1;
					if (i - j + 1 > max) {
						max = i - j + 1;
					}
				}
			}
		}
	}
	if (max == 0) {
		cout << 1 << '\n';
	}
	else {
		cout << max << '\n';
	}

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值