PAT甲级 A1108

PAT甲级 A1108

题目详情

1108 Finding Average (20分)
The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:
For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
Sample Output 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
Sample Input 2:
2
aaa -9999
Sample Output 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

解题思路

这道题写的我心态爆炸。C++写的最大的问题就是解析字符串。其中对于字符串解析中最大的坑在于 这道题给你的测试点.1111或者1111.也判断是对的 把我给写吐了
第二点就是要注意numbers的单复数,加不加s,又把我找吐了
把我心态写炸了
以下为AC代码

#include<algorithm>
#include<iostream>
#include<vector>
#include<cmath>
#include<iomanip>
#include<map>
#include<queue>
#include<string>
using namespace std;
int N;
string ques[200];
double tans = 0;
bool islegal(string a) {//判断输入是否合法
	vector<int> small;
	vector<int> big;
	int nos = 0;
	int neg = 1;
	for (int i = 0; i < a.size(); i++) {
		if (i == 0 && a[i] == '-') {
			neg = -1;
			continue;
		}
		if (a[i] == '.'&&nos==0) {
			nos = 1;
			continue;

		}
		if (a[i] > '9' || a[i]<'0') {
			return false;
		}
		if(a[i]>='0'&&a[i]<='9'){
			if (nos == 0) {
				big.push_back(a[i] - '0');
			}
			else {
				small.push_back(a[i] - '0');
			}
		}
	}
	if (big.size() == 0 && small.size() == 0) {
		return false;
	}
	double temps = 0;
	int tt = 1;
	for (int i = big.size()-1; i >= 0; i--) {
		temps += big[i] * tt;
		tt = tt * 10;
	}
	if (nos == 1) {
		if (small.size() >= 3) {
			return false;
		}
		double kk = 0.1;
		for (int i = 0; i < small.size(); i++) {
			temps += small[i] * kk;
			kk = kk * 0.1;
		}
	}
	temps = temps * neg;
	if (temps > 1000 || temps < -1000) {
		return false;
	}
	tans = temps;
	return true;
}
int main() {
	cin >> N;
	int t = 0;
	double sum = 0;
	for (int i = 0; i < N; i++) {
		string temp;
		cin >> temp;
		if (islegal(temp)) {
			t++;;
			sum += tans;
		}
		else {
			cout << "ERROR: " << temp << " is not a legal number"<<'\n';
			continue;
		}
	}
	if (t == 1) {
		cout << "The average of " << t << " number is " << fixed << setprecision(2) << (sum) << '\n';
	}
	else if (t > 1) {
		cout << "The average of " << t << " numbers is " << fixed << setprecision(2) << (sum / (t * 1.0)) << '\n';
	}
	else {
		cout << "The average of 0 numbers is Undefined" << '\n';
	}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值