PAT甲级 A1045

PAT甲级 A1045

题目详情

1045 Favorite Color Stripe (30分)
Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva’s favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva’s favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva’s favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤10e4) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:
For each test case, simply print in a line the maximum length of Eva’s favorite stripe.

Sample Input:
6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6
Sample Output:
7

解题思路

这道题应该是经典的LCS问题。LCS即为最长不降自序列问题,在该问题中,需要找出某一串中的最长的不下降的子序列。最长不降子序列为典型的动态规划dp区间规划问题,每次遍历时通过dp数组存储以当前元素结尾的可能字符串的长度
以下为AC代码

#include<iostream>
#include<string>
#include<vector>
#include<cmath>
#include<memory.h>
#include<string>
#include<algorithm>
#include<iomanip>
#include<map>
using namespace std;//动态规划问题 LIS最长不下降子序列
int C,N;
int color[201] = { 0 };
int main() {
	cin >> C;
	cin >> N;
	for (int i = 1; i <= N; i++) {
		int temp; cin >> temp;
		color[temp] = i;
	}
	int M;
	cin >> M;
	vector<int> stripe;
	for (int i = 0; i < M; i++) {
		int temp; cin >> temp;
		if (color[temp] > 0) {
			stripe.push_back(color[temp]);//存入子序列的顺序
		}
	}
	int dp[10001]; int maxn = -1;
	for (int i = 0; i<stripe.size(); i++) {
		dp[i] = 1;
		for (int j = 0; j < i; j++) {
			if (stripe[i] >= stripe[j] && (dp[j] + 1 > dp[i])) {
				dp[i] = dp[j] + 1;
			}
		}
		maxn = max(maxn, dp[i]);
	}
	cout << maxn << '\n';
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值