PAT甲级 A1046

PAT甲级 A1046

题目详情

1046 Shortest Distance (20分)
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,10
​e5​​ ]), followed by N integer distances D1,D​2⋯ DN, where D​i is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10e​4), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10e7
​​ .

Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7

解题思路

这道题是很简单的模拟题(所以才20分),题目中让我们求两个出口之间的最短距离,由于高速公路为一个环,其距离的总和为环的周长,两个点的最短距离即为环内的直接正向距离和通过总距离相减的反向距离。我们用一个数组,存储每次从1到该出口的正向距离,任意两个出口的正向距离即可用数组内两元素差直接得到
以下为AC代码

#include<iostream>
#include<string>
#include<vector>
#include<cmath>
#include<memory.h>
#include<string>
#include<algorithm>
#include<iomanip>
#include<map>
using namespace std;
vector<int> save;
vector<int> positive;
int main() {
	int N; cin >> N;
	positive.push_back(0);
	int total = 0;
	for (int i = 0; i < N; i++) {
		int temp; scanf_s("%d", &temp);
		save.push_back(temp);
		total += temp;
		positive.push_back(positive[i] + temp);
	}
	int M; cin >> M;
	for (int i = 0; i < M; i++) {
		int c1, c2; cin >> c1 >> c2;
		int dis;
		if (c2 > c1) {
			int dis1 = positive[c2 - 1] - positive[c1 - 1];
			int dis2 = total - dis1;
			dis = min(dis1, dis2);
		}
		else if (c2 < c1) {
			int dis1 = positive[c1 - 1] - positive[c2 - 1];
			int dis2 = total -dis1;
			dis = min(dis1, dis2);
		}
		else {
			cout << "0" << '\n';
			continue;
		}
		cout << dis << '\n';
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值