(kmp) Number Sequence

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

题意:给你两个序列a,b,找出b序列在a中出现的位置,利用kmp算法

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
int t[1000005], p[10005];
int NEXT[10005];
int n, m;
void getnext(int p[])
{
    int i = 0, j = -1;
    NEXT[0] = -1;
    while(i<m)
    {
        if(j==-1||p[i]==p[j])
        {
            i++;
            j++;
            NEXT[i] = j;
        }
        else
            j = NEXT[j];
    }
}
int kmp(int t[], int p[])
{
    int i = 0, j = 0;
    while(i<n&&j<m)
    {
        if(j==-1||t[i]==p[j])
            i++, j++;
        else
            j = NEXT[j];
    }
    if(j>=m)
        return i - m + 1;
    else
        return -1;
}
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        cin>>n>>m;
        for(int i=0;i<n;i++)
            cin>>t[i];
        for(int i=0;i<m;i++)
            cin>>p[i];
        if(n<m)
            printf("-1\n");
        else
        {
        getnext(p);
        printf("%d\n", kmp(t, p));
        }
    }
    return 0;
}

kmp算法

规定i是主串S的下标,j是模式T的下标。现在假设现在主串S匹配到 i 位置,模式串T匹配到 j 位置。

如果j = -1,则i++,j++,继续匹配下一个字符;
如果S[i] = T[j],则i++,j++,继续匹配下一个字符;
如果j != -1,且S[i] != P[j],则 i 不变,j = next[j]。此举意味着失配时,接下来模式串T要相对于主串S向右移动j - next [j] 位。
 

int KMP(int start,char S[],char T[])
{
	int i=start,j=0;
	while(S[i]!='\0'&&T[j]!='\0')
	{
		if(j==-1||S[i]==T[j])
		{
			i++;         //继续对下一个字符比较 
			j++;         //模式串向右滑动 
		}
		else j=next[j];
	}
	if(T[j]=='\0') return (i-j);    //匹配成功返回下标 
	else return -1;                 //匹配失败返回-1 
}

可参考详解:https://www.cnblogs.com/dilthey/p/8620119.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值