Trees on the level HDU - 1622

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics. 

This problem involves building and traversing binary trees. 
Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes. 

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1. 

For example, a level order traversal of the tree 

 
is: 5, 4, 8, 11, 13, 4, 7, 2, 1. 

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once. 
 

Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses. 

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file. 
 

Output

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete

题意与思路:

就是给你一些数据让你判断是否可以构成二叉树,能够成的话,就输出前序,否则输出not complete;

我这里也没有建树,经过排序就得到所需要的答案了。详细思想我都在代码里注释了。

代码如下:

​
#include<stdio.h>
#include<string.h>
#include<string>
#include<iostream>
#include<map>
#include<algorithm>
using namespace std;
string s;
int k;
struct node
{
    int x;
    string a;
} q[12000];
void build()//存储过程
{
    int sum=0;
    string b;
    b.clear();
    for(int i=1; i<s.size()-1; i++)
    {
        if(s[i]>='0'&&s[i]<='9')
            sum=sum*10+s[i]-'0';
        else if(s[i]=='L')
            b=b+'L';
        else if(s[i]=='R')
            b=b+'R';
    }
    q[k].x=sum;
    q[k++].a=b;
}
bool cmp(node x,node y)//这个排序只要树能构成,排序后的就是要求输出的结果
{
    if(x.a.size()==y.a.size())//长度相等按字典序
        return x.a<y.a;
    else
        return x.a.size()<y.a.size();//长度不相等按长度
}
int main()
{
    s.clear();
    while(cin>>s)
    {
        k=0;
        if(s=="()")//如果一开始就是()就结束输入了,直接输出continue掉
        {
            printf("not complete\n");
            continue;
        }
        build();
        while(1)
        {
            s.clear();
            cin>>s;
            if(s=="()")
                break;
            build();
        }
        sort(q,q+k,cmp);
        int flag=0;
        if(q[0].a.length()!=0)//这里是判断排序后第一个是否满足是根的要求
            flag=1;
        if(flag==0)
        {
            for(int i=1; i<k; i++)
            {
                int ans=0;
                for(int j=0; j<i; j++)//判断到这个点的路径之前是否出现过
                    if(q[i].a==q[j].a)
                        ans=1;
                if(ans==1)
                {
                    flag=1;
                    break;
                }
                ans=0;
                string aa="";
                for(int h=0; h<q[i].a.size()-1; h++)//这个地方就是把最后一个去掉为下面判断前面是否有结点做准备
                    aa=aa+q[i].a[h];
                for(int t=0; t<i; t++)
                    if(q[t].a==aa)//判断排序后它的前面是否有属于它的结点
                        ans=1;
                if(ans==0)
                {
                    flag=1;
                    break;
                }
            }
        }
        if(flag==1)
        {
            printf("not complete\n");//自己一开始做出来提交wa,
            continue;              //然后发现这个输出居然写成printf("not impossible\n");
        }                          //对自己都无语死了,不过最后做出来还是很开心
        else
        {
            printf("%d",q[0].x);
            for(int i=1; i<k; i++)
                printf(" %d",q[i].x);
            printf("\n");
        }
    }
    return 0;
}

​

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值