poj 3909 Stock Exchange

Stock Exchange
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9520 Accepted: 3269
Description

The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising trends. Given a sequence of numbers p1, p2,…,pn representing stock prices, a rising trend is a subsequence pi1 < pi2 < … < pik, with i1 < i2 < … < ik. John’s problem is to find very quickly the longest rising trend.
Input

Each data set in the file stands for a particular set of stock prices. A data set starts with the length L (L ≤ 100000) of the sequence of numbers, followed by the numbers (a number fits a long integer).
White spaces can occur freely in the input. The input data are correct and terminate with an end of file.
Output

The program prints the length of the longest rising trend.
For each set of data the program prints the result to the standard output from the beginning of a line.
Sample Input

6
5 2 1 4 5 3
3
1 1 1

4
4 3 2 1
Sample Output

3
1
1
Hint

There are three data sets. In the first case, the length L of the sequence is 6. The sequence is 5, 2, 1, 4, 5, 3. The result for the data set is the length of the longest rising trend: 3.

题目大意:典型的求单调最长子序列。
这题注意的一点就是题目的n很大,不能用平时的O(n^2)算法,否则会超时,其实该题可以用二分搜索来求,可以手写代码,也可直接用lower_bound模板。
例如 例子中的5 2 1 4 5 3
第一步初始化dp为INF

a521453
dpINFINFINFINFINFINF

第二步找到dp中每第一个大于a等于[i]的值并替换为a[i]
i = 1

a521453
dp5INFINFINFINFINF

i= 2

a521453
dp2INFINFINFINFINF

i = 3

a521453
dp1INFINFINFINFINF

i = 4

a521453
dp14INFINFINFINF

i = 5

a521453
dp145INFINFINF

i = 6

a521453
dp135INFINFINF

故dp数组存的即为最长单调序列,其长度为第一个INF值下标的值减去dp首地址(注意这里首地址下标为1)

附上AC代码

#include <cstdio>
#include <algorithm>
#define INF 0x3f3f3f3f
using namespace std;

int main()
{
    int n,i,j;
    while(scanf("%d",&n)!=EOF)
    {
        int dp[n],a[n];
        for(i=0;i<n;++i)
        {
            scanf("%d",&a[i]);
            dp[i]=INF;
        }
        for(i=0;i<n;++i)
            *lower_bound(dp,dp+n,a[i])=a[i];		//找每第一个大于等于a[i]的值并赋予,这样在最后就形成了一个递增序列,其长度就为最长子序列长度
        printf("%d\n",lower_bound(dp,dp+n,INF)-dp);		//INF所在dp数组的位置即为最长子序列
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值