hdu 1796

HDU 1796

How many integers can you find
Time Limit: 12000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12255 Accepted Submission(s): 3665

Problem Description
Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

Input
There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.

Output
For each case, output the number.

Sample Input
12 2
2 3

Sample Output
7

先考虑只有一个数的情况,则小于n且能被该数p整除的数有(n-1)/p;当m集合里面的数位两个时,则每个数单独整除小于n的数的个数为(n-1)/p1,(n-1)/p2,两个加起来还包括了p1和p2的最小公倍数能整除的个数,故还要减去(n-1)/lcm(p1,p2),推广到n,则明显为容斥原理.

附上AC代码:
注意细节

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>

using namespace std;

int n, m, cnt;
long long ans, a[20];

long long gcd(long long a, long long b)
{
    return b == 0 ? a : gcd(b,a%b);
}
//cur表示当前的数
//lcm表示最小公倍数
//id表示选了几个数,奇数则加,偶数则减
void dfs(int cur, long long lcm, int id)
{
    lcm = a[cur]/gcd(a[cur],lcm)*lcm;
    if(id&1)
        ans += (n-1)/lcm;
    else ans -= (n-1)/lcm;
    for(int i = cur + 1; i < cnt; i++)
    {
        dfs(i,lcm,id+1);
    }
}
int main()
{
    while(~scanf("%d%d", &n, &m))
    {
        cnt = 0;
        for(int i = 0; i < m; ++i)
        {
            int x;
            scanf("%d", &x);
            if(x!=0) a[cnt++]=x; 		//注意除数不能为零
        }
        ans = 0;
        for(int i = 0; i < cnt; ++i)
        {
            dfs(i,a[i],1);
        }
        cout << ans << endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值