HDU 2298 Toxophily (三分+二分)

Toxophily

The recreation center of WHU ACM Team has indoor billiards, Ping Pang,
chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing,
climbing, and so on. We all like toxophily.

Bob is hooked on toxophily recently. Assume that Bob is at point (0,0)
and he wants to shoot the fruits on a nearby tree. He can adjust the
angle to fix the trajectory. Unfortunately, he always fails at that.
Can you help him?

Now given the object’s coordinates, please calculate the angle between
the arrow and x-axis at Bob’s point. Assume that g=9.8N/m.

Input

The input consists of several test cases. The first line of input
consists of an integer T, indicating the number of test cases. Each
test case is on a separated line, and it consists three floating point
numbers: x, y, v. x and y indicate the coordinate of the fruit. v is
the arrow’s exit speed. Technical Specification

  1. T ≤ 100.
  2. 0 ≤ x, y, v ≤ 10000.

Output

For each test case, output the smallest answer rounded to six
fractional digits on a separated line. Output “-1”, if there’s no
possible answer.

Please use radian as unit.

Sample Input
3
0.222018 23.901887 121.909183
39.096669 110.210922 20.270030
138.355025 2028.716904 25.079551
Sample Output
1.561582
-1
-1

题意:
从坐标为(0,0)的地方射出一支初速度为v的箭,想要射中坐标在(x,y)的靶子的话,射出时箭与地面的夹角应是多少?重力加速度G=9.8
思路:
假设所求角为θ,那么可以将速度进行分解,分解成水平向右的速度和竖直向上的速度
Vx=vcos(θ),Vy=vsin(θ)
则:X=Vxt,Y=Vyt-1/2gt*t;
进行合并可以将t消除,就可以知道Y了
那么你可以先用三分求出最高的高度,然后再通过二分求出θ
这道题需要注意的点一个是精度问题,还有一个是特殊情况,当靶子在远点正上方的话需要特判

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<iostream>
#include<math.h>
#include<queue>
#include<iomanip>
#define ll long long
using namespace std;
const int inf=0x3f3f3f3f;
int s[50005];
double x,y,v;
double g=9.80;
double solve(double k)
{
    double t=x/(v*cos(k));
    return v*sin(k)*t-1.0/2*g*t*t;
}
int  main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf%lf",&x,&y,&v);
        double l=0,r=acos(-1)/2;
        if(x==0)
        {
            if(v*v/2/g<y)
            {
                printf("-1\n");

            }
            else
            {
                printf("%.6lf\n",r);
            }
            continue;
        }
        double mid1,mid2,mid;
        while(r-l>1e-8)
        {
            mid1=(l+r)/2;
            mid2=(mid1+r)/2;
            if(solve(mid1)<solve(mid2))
            {
                l=mid1;
            }
            else
            {
                r=mid2;
            }
        }
        if(solve(r)<y)
        {
            printf("-1\n");
            continue;
        }
        l=0;

        while(r-l>1e-8)
        {
            mid=(l+r)/2;
            if(solve(mid)<y)
            {
                l=mid;
            }
            else
            {
                r=mid;
            }
        }
        printf("%.6lf\n",mid);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值