HDU 2298 Toxophily(二分+数学)

Toxophily

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 729    Accepted Submission(s): 427

Problem Description
The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on.
We all like toxophily.
Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him?
Now given the object's coordinates, please calculate the angle between the arrow and x-axis at Bob's point. Assume that g=9.8N/m.
Input
The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow's exit speed.
Technical Specification
1. T ≤ 100.
2. 0 ≤ x, y, v ≤ 10000. 
Output
For each test case, output the smallest answer rounded to six fractional digits on a separated line.
Output "-1", if there's no possible answer.
Please use radian as unit. 
Sample Input
 
 
3 0.222018 23.901887 121.909183 39.096669 110.210922 20.270030 138.355025 2028.716904 25.079551
Sample Output
 
 
1.561582 -1 -1
题意:一个射击游戏默认人的位置为(0,0),物品的位置给出为(x,y),箭的射速为v, vx=cosa*v t=x/vx y=vy*t-0.5*g*t*t 显然有三种情况: 1.做上升减速运动时根本就达不到y的高度 2.正好达到了最高的高度 3.做减速运动到0时上升的高度大于y
对应三种情况: 1.角度偏小 2.所求解 3.角度偏大 
2情况是所求解是因为一个解如果角度最小那么他的达到y时的速度一定为0
#include <stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#define pi acos(-1.0)
#define a 9.8
using namespace std;
double v;	
double x,y;
bool judge;
double check(double mid)
{
	double vx,vy,t;
	vx=cos(mid)*v;
	vy=sin(mid)*v;
	t=x/vx;
	double leny=vy*t-0.5*a*t*t;
	if(leny<y)
	return -1;//l变大 
	if(leny>y)//还没变成0
	{
		judge=1;	
		return 1;//r变小 
	}
	else
	{
		judge=1;
		return 0;
	}
}
int main(int argc, char *argv[])
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lf %lf %lf",&x,&y,&v);
		double l=0,r=pi/2,mid;
		judge=0;
		while(fabs(l-r)>0.00000001)
		{
			mid=(l+r)/2;
			if(check(mid)==-1)
			{
				l=mid+0.00000001;	
			}
			if(check(mid)==1)
			r=mid-0.00000001;
			if(check(mid)==0)
			{
				break;
			}
		}
		if(judge==0)
		{
			printf("-1\n");
		}
		else
		{
			printf("%.6lf\n",mid);
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值