A-Dinner (NBUT-1217)

Description

Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife and other tableware is not enough in the kitchen, Little A goes to take backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if “basketball” is written on the box, which means the box contains only basketball. With these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.

Input

There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.

Output

For each test of the input, output all the name of tableware.

Sample Input

3 basketball fork chopsticks
2 bowl letter

Sample Output

fork chopsticks
bowl

Hint

The tableware only contains: bowl, knife, fork and chopsticks.

题目大意:要去厨房里拿餐具,餐具装在箱子里,箱子上面是餐具的名字,需要的餐具为bowl, knife, fork and chopsticks.

思路:直接暴力就可以,但是得注意输出空格的格式,每两个餐具之间有一个空格,但是最后一个输出的餐具后面没有空格输出,还有不用考虑餐具相同的情况,如果有两个 bowl 的话直接输出两个就完事。

#include <iostream>
#include<string.h>
#include<algorithm>
#include<stdio.h>
using namespace std;
char s[200];
int main()
{
   int n;
   while(scanf("%d",&n)!=EOF)
   {
    if(n==0)
    {
        continue;
    }
   int r=0;//r如果是0的话就表明输出的是第一个餐具,然后前面不加空格,之后的餐具前要加空格
   for(int i=1;i<=n;i++)
   {
       scanf("%s",s);
       int a=strlen(s);
       if(a==4||a==5||a==10)
       {
           if(s[0]=='b'&&s[1]=='o'&&s[2]=='w'&&s[3]=='l')
           {
               if(r!=0)
               {
                   printf(" bowl");
               }

               else
               {
                   printf("bowl");
               }
               r++;
           }
           else if(s[0]=='f'&&s[1]=='o'&&s[2]=='r'&&s[3]=='k')
            {
                if(r!=0)
                {
                    printf(" fork");
                }

                else
                {
                    printf("fork");
                }

                r++;
            }
            else if(s[0]=='k'&&s[1]=='n'&&s[2]=='i'&&s[3]=='f'&&s[4]=='e')
            {
                if(r!=0)
                {
                    printf(" knife");
                }
                else
                {
                    printf("knife");
                }
                r++;

            }
            else if(s[0]=='c'&&s[1]=='h'&&s[2]=='o'&&s[3]=='p'&&s[4]=='s'&&s[5]=='t'&&s[6]=='i'&&s[7]=='c'&&s[8]=='k'&&s[9]=='s')
            {
                if(r!=0)
                {
                    printf(" chopsticks");
                }
                else
                {
                    printf("chopsticks");
                }
                r++;

            }

       }
   }

   printf("\n");
   }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 内容概要 《计算机试卷1》是一份综合性的计算机基础和应用测试卷,涵盖了计算机硬件、软件、操作系统、网络、多媒体技术等多个领域的知识点。试卷包括单选题和操作应用两大类,单选题部分测试学生对计算机基础知识的掌握,操作应用部分则评估学生对计算机应用软件的实际操作能力。 ### 适用人群 本试卷适用于: - 计算机专业或信息技术相关专业的学生,用于课程学习或考试复习。 - 准备计算机等级考试或职业资格认证的人士,作为实战演练材料。 - 对计算机操作有兴趣的自学者,用于提升个人计算机应用技能。 - 计算机基础教育工作者,作为教学资源或出题参考。 ### 使用场景及目标 1. **学习评估**:作为学校或教育机构对学生计算机基础知识和应用技能的评估工具。 2. **自学测试**:供个人自学者检验自己对计算机知识的掌握程度和操作熟练度。 3. **职业发展**:帮助职场人士通过实际操作练习,提升计算机应用能力,增强工作竞争力。 4. **教学资源**:教师可以用于课堂教学,作为教学内容的补充或学生的课后练习。 5. **竞赛准备**:适合准备计算机相关竞赛的学生,作为强化训练和技能检测的材料。 试卷的目标是通过系统性的题目设计,帮助学生全面复习和巩固计算机基础知识,同时通过实际操作题目,提高学生解决实际问题的能力。通过本试卷的学习与练习,学生将能够更加深入地理解计算机的工作原理,掌握常用软件的使用方法,为未来的学术或职业生涯打下坚实的基础。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值