POJ 2387 Til the Cows Come Home (dijkstra)

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1…N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

  • Line 1: Two integers: T and N

  • Lines 2…T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1…100.

Output

  • Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
    Sample Input
    5 5
    1 2 20
    2 3 30
    3 4 20
    4 5 20
    1 5 100

Sample Output

90

Hint

INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

做的第一道最短生成路题,应该算是入门题吧,刚学迪杰斯特拉算法感觉好难,看了好久才看懂了(看的我难受),然后用迪杰斯特拉算法把这道题A了,建议用多种做法把这道题算一遍,毕竟是模板题。如果对迪杰斯特拉算法不了解的话可以看下这个链接,感觉写的很好 https://blog.51cto.com/ahalei/1387799

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<iostream>
using namespace std;
int e[1010][1010],book[1005];
int dis[1005];
int main()
{
    int m,n,x1,x2,x3;
    int inf=99999999;

    scanf("%d%d",&m,&n);
    memset(e,0,sizeof(e));
    memset(dis,0,sizeof(dis));
    memset(book,0,sizeof(book));

    for(int a=1;a<=n;a++)
    {
        for(int b=1;b<=n;b++)
        {
            e[a][b]=inf;
        }
    }
    for(int a=1;a<=m;a++)
    {
        scanf("%d%d%d",&x1,&x2,&x3);
        if(x3<e[x1][x2])
        {
        e[x1][x2]=x3;
        e[x2][x1]=x3;
        }

    }
    for(int b=1;b<=n;b++)
    {
        dis[b]=e[1][b];
        book[b]=0;
    }

    int u,min1;
    for(int a=1;a<=n;a++)
    {
        min1=inf;
        u=0;
        for(int b=1;b<=n;b++)
        {
            if(book[b]==0&&dis[b]<min1)
            {
              min1=dis[b];
              u=b;
            }
        }
        book[u]=1;
        for(int b=1;b<=n;b++)
        {
            if(e[u][b]<inf)
            {
                if(book[b]==0&&dis[b]>e[u][b]+dis[u])  //必须有book[b]==0这个判断,要不然会报错
                {
                    dis[b]=e[u][b]+dis[u];
                }
            }
        }

    }
    printf("%d",dis[n]);

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值