HDU 4722 (good numbers)找规律

Description

If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.
You are required to count the number of good numbers in the range from A to B, inclusive.

Input

The first line has a number T (T <= 10000) , indicating the number of test cases.
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 10 18).

Output

For test case X, output "Case #X: " first, then output the number of good numbers in a single line.

Sample Input

2
1 10
1 20

Sample Output

Case #1: 0
Case #2: 1

Hint

The answer maybe very large, we recommend you to use long long instead of int.

这道题我用的是找规律的方法,每100个数就有10个好数字(注意0-9中0就是那个好数字),判断 m到n 之间的好数字可以判断0到m之间的好数字减去0到n之间的好数字,如果你输入456这个数字,前400个数就有40个,然后判断从400到456中间有多少个好数字就行了,还有就是你判断 m,n之间的好数字调用函数时最后应该是 lsz(n)-lsz(m-1),为什么这样呢?比如判断19-20之间的好数字, 0到19好数字2个,0到20好数字2个,lsz(20)-lsz(19)岂不是0了,正确答案为1,所以应该判断到小树(19)前面那一个数(18),然后0到18之间的好数字是1,0到20之间的好数字是2,然后相减答案为1

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include<iostream>
using namespace std;
long long int sum,x,y,z,tem;
long long int lsz(long long m)
{
    if(m<0)
        return 0;
    x=m/100;
    sum=x*10;
    for(long long a=x*100;a<=m;a++)
    {
        tem=0;
        y=a;
        while(y!=0)
        {
            tem+=y%10;
             y=y/10;
        }
        if(tem%10==0)
        {
            sum++;
        }
    }
    return sum;

}
int main()
{
    int l=1;
    long long int t,m,n;
    scanf("%lld",&t);
    while(t--)
    {
        long long int ans;
        scanf("%lld%lld",&m,&n);
        ans=lsz(n)-lsz(m-1);
        printf("Case #%d: %lld\n",l++,ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值