HDU 1698 just a hook(线段树懒人标记)

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

在这里插入图片描述

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
Sample Input
1
10
2
1 5 2
5 9 3
Sample Output
Case 1: The total value of the hook is 24.
题意:有m个钩子,初始的时候钩子都是铜钩子,伤害为1,然后有n种操作,每个操作有三个数,l,r,c表示讲从l到r的钩子的价值换成c,最后输出所有钩子的价值总和
思路:一道线段树懒惰标记的一道入门题,只要会了线段数基本操作,然后学一下懒惰标记就行了,给一个懒惰标记的讲解,讲的很清楚,不懂的可以看一下

https://blog.csdn.net/kaisa158/article/details/47260663 这个懒惰标记讲的很不错

#include<algorithm>
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<queue>
#include<stack>
#include<math.h>
using namespace std;
int add[410000],sum[410000];
void pushup(int i)
{
    sum[i]=sum[i<<1]+sum[i<<1|1];
}
void pushdown(int i,int m)
{
    if(add[i])
    {
        add[i<<1]=add[i];
        add[i<<1|1]=add[i];
        sum[i<<1|1]=add[i]*(m>>1);
        sum[i<<1]=add[i]*(m-(m>>1));
        add[i]=0;
    }
}
void build(int i,int l,int r)
{
    add[i]=0;
    if(l==r)
    {
        sum[i]=1;
        return ;
    }
    int mid=(l+r)>>1;
    build(i<<1,l,mid);
    build(i<<1|1,mid+1,r);
    pushup(i);
}
void update(int ll,int rr,int c,int i,int l,int r)
{
    if(ll<=l&&r<=rr)
    {
        add[i]=c;
        sum[i]=(r-l+1)*c;
        return ;
    }
    pushdown(i,r-l+1);
    int mid=(r+l)/2;
    if(mid>=ll)
    {
        update(ll,rr,c,i*2,l,mid);
    }
    if(mid<rr)
    {
        update(ll,rr,c,i<<1|1,mid+1,r);
    }
    pushup(i);
}
int main()
{
    int z=1,t;
    scanf("%d",&t);
    while(t--)
    {
        int m;
        scanf("%d",&m);
        build(1,1,m);
        int n;
        scanf("%d",&n);
        while(n--)
        {
            int ll,rr,c;
            scanf("%d%d%d",&ll,&rr,&c);
            update(ll,rr,c,1,1,m);
        }
        printf("Case %d: The total value of the hook is %d.\n",z++,sum[1]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值