HDU-2199 Can you solve this equation?(二分)

Can you solve this equation?

Problem Description
Now,given the equation 8x^4 + 7x^3 + 2x^2 + 3x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input
2
100
-4

Sample Output
1.6152
No solution!

题意:给了一个方程,输入的是这个方程的值Y,需要求在[0,100]这个区间中是否存在函数的解x。

思路:因为题目给定的x是在[0,100]这个区间中的,所以可以在这个区间内进行二分查找,当找到的值代入方程求出的的值等与Y则说明找到了。

注意,Y如果小于6(当x=0时方程的值)或者Y大于当x=100时方程的值的话就不存在x的解。

#include<cstdio>
#include<cstring>
#include<set>
#include<map>
#include<iostream>
#include<algorithm>
using namespace std;

#define ll long long
const int inf=0x3f3f3f3f;
const int maxn=1000010;
#define eps 1e-10

double y;

double cal(double x)
{
    return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}

void binary_Search()
{
    double L=0,R=101,mid,tmp;
    while(R-L>=eps)
    {
        mid=(L+R)/2.0;
        tmp=cal(mid);
        if(tmp<y) L=mid;
        else if(tmp>y) R=mid;
        else break;
    }
    printf("%.4lf\n",mid);
}

int main()
{
    double maxx=cal(100);
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf",&y);
        if(y<6.0||y>maxx) printf("No solution!\n");
        else
        binary_Search();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值