HDU - 2639 Bone Collector II(01背包的第K优解)

1 篇文章 0 订阅

Bone Collector II

Problem Description
The title of this problem is familiar,isn’t it?yeah,if you had took part in the “Rookie Cup” competition,you must have seem this title.If you haven’t seen it before,it doesn’t matter,I will give you a link:

Here is the link:http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum … to the K-th maximum.

If the total number of different values is less than K,just ouput 0.

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output
One integer per line representing the K-th maximum of the total value (this number will be less than 231).

Sample Input
3
5 10 2
1 2 3 4 5
5 4 3 2 1
5 10 12
1 2 3 4 5
5 4 3 2 1
5 10 16
1 2 3 4 5
5 4 3 2 1

Sample Output
12
2
0

题意:有n个物品,容量为v,给出每个物品的价值和体积,要求第K个最大值。

思路:之前做到过这道题的弱化版,就是一个普通的01背包,这题就是要我们在01背包的前提下求第K个最大值,可以把数组多开一维(dp[j][k])用来存储放当前这个物品时的第1-k个最优解(最优解就代表此时的最大值)。

vol[i]为物品的体积,val[i]为物品的价值
对于普通的01背包的转移方程是:
dp[j]=max(dp[j],dp[j-vol[i]]+val[i]);
对第K优解其实也一样,因为只有放或者不放两种状态
所以可以开两个数组来存这两种状态
a[p]=dp[j][p];
b[p]=dp[j-vol[i]][p]+val[i];
然后把他们排序,最后dp[v][k]就是要求的第K优解。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<set>
#include<map>
#include<queue>
#include<iostream>
#include<algorithm>
using namespace std;

#define ll long long
const int inf = 0x3f3f3f3f;
const int maxn = 1010;
#define eps 1e-8

int dp[maxn][50],val[maxn],vol[maxn],a[maxn],b[maxn];

int main()
{
	int t,n,m,k;
	cin>>t;
	while(t--)
	{
		cin>>n>>m>>k;
		memset(dp,0,sizeof(dp));
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		for(int i=1; i<=n; i++)
			cin>>val[i];
		for(int i=1; i<=n; i++)
			cin>>vol[i];
		for(int i=1; i<=n; i++)
		{
			for(int j=m; j>=vol[i]; j--)
			{
				for(int p=1; p<=k; p++)
				{
					a[p]=dp[j][p];
					b[p]=dp[j-vol[i]][p]+val[i];
				}
				a[k+1]=-1;
				b[k+1]=-1;
				int x=1,y=1,z=1;
				while(z<=k&&(a[x]>=0||b[x]>=0))
				{
					if(a[x]>b[y])
						dp[j][z]=a[x++];
					else dp[j][z]=b[y++];
					if(dp[j][z]!=dp[j][z-1]) z++;
				}
			}

		}
		cout<<dp[m][k]<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值