约瑟夫问题(循环链表)

18 篇文章 3 订阅

约瑟夫问题

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

n个人想玩残酷的死亡游戏,游戏规则如下: 

n个人进行编号,分别从1到n,排成一个圈,顺时针从1开始数到m,数到m的人被杀,剩下的人继续游戏,活到最后的一个人是胜利者。

请输出最后一个人的编号。

Input

输入n和m值。

Output

输出胜利者的编号。

Sample Input

5 3

Sample Output

4

Hint

第一轮:3被杀第二轮:1被杀第三轮:5被杀第四轮:2被杀

 

注意:

1. game函数中判断 i = m 时,else一定要加上,否则是错的

2. game函数中令 q 指向 tail 前驱结点时,需要令 q 遍历一遍链表才能做到

 

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int number;
    struct node *next;
};
struct node * Circular_Linked_List(int);
int game(struct node *, int);
int main()
{
    int n, m;
    struct node *head;
    scanf("%d %d", &n, &m);
    head = Circular_Linked_List(n);
    printf("%d\n", game(head, m));
    return 0;
}
struct node * Circular_Linked_List(int n)
{///创建循环链表
    int i;
    struct node *head, *tail, *p;
    head = (struct node *)malloc(sizeof(struct node));
    head->next = NULL;
    tail = head;
    for(i = 1; i <= n; i++)
    {
        p = (struct node *)malloc(sizeof(struct node));
        p->number = i;
        tail->next = p;
        tail = p;
    }
    tail->next = head->next;
    return head;
};

int game(struct node *head, int m)
{///在链表中循环,直到剩下一个结点元素时结束循环,并将该结点的编号返回
    int i;
    struct node *q, *tail;///游动指针及其前驱指针
    q = head;
    tail = q->next;
    i = 1;
    while(q->next != head->next)  q = q->next;
    ///遍历一遍链表,令 q 指向尾结点
    while(tail->next != tail)
    {///循环链表,当指针指向自己时,即只剩下一个元素时
        if(i == m)///注意此处不要习惯性把 m 写成 样例的数字了!!!
        {///当计数到 m 时,删除该结点
            q->next = tail->next;
            free(tail);
            tail = q->next;
            i = 1;
        }
        else///这个 else 必须要加上!!!否则会出错
        {///会导致指针 tail 和计数变量 i 不对应
            q = q->next;
            tail = tail->next;
            i++;///计数变量必须和指针 tail 对应,要动一起动!
        }///这段程序不能放在 if 前面,否则指针开始时就后移
    }///会漏判一次,导致错误
    return tail->number;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值