POJ3253 FJUT3810 优先队列解决哈夫曼树带权路径长度WPL问题

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the “kerf”, the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn’t own a saw with which to cut the wood, so he mosies over to Farmer Don’s Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn’t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input
Line 1: One integer N, the number of planks
Lines 2… N+1: Each line contains a single integer describing the length of a needed plank
Output
Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts
SampleInput
3
8
5
8
SampleOutput
34
题意 :给你一快木板 切割成所需的几块 切割的价钱随长度递增 求最小花费

思路:逆向思维一下 将问题转化为由几块木板合成一个木板 所求最小花费, 由此想到哈夫曼树。

下面献上我的low逼代码

#include <iostream>
#include <queue>

using namespace std;

typedef long long LL;///  int -> 则 WA

priority_queue<LL,vector<LL>, greater<LL> >que;///优先队列维护 使最短的木板在堆顶

int main()
{
    int n;

    cin >> n;

    while(!que.empty())
        que.pop();

    for(int i=0; i<n; i++)
    {
        int x;
        cin >> x;
        que.push(x);
    }

    LL res=0;
    while(que.size()>=2)
    {
        LL x=que.top();///每次取出最短的两条木板 则可保证花费最小
        que.pop();
        LL y=que.top();
        que.pop();
        res+=x+y;
        que.push(x+y);
    }

    cout << res <<endl;
    
    return 0;
}

下面再贴一道版题 其实只要有这个思维就好了
moxin的郭先生有一根魔法棒,郭先生很喜欢这根魔法棒,但是有一天它断成了好几段

然后郭先生就拜托moxin把他的魔法棒修好,修魔法棒是要付出软妹币的,moxin心疼自己的钱,于是moxin要求你给出修复魔法棒的最少花费,每修护一段魔法棒,所要花费的钱是两段魔法棒的权值总和

Input
给出一个n,代表魔法棒断成了n段(2 <= n <= 10000)

接下来给出n段魔法棒代表的权值(1 <= ai <= n)

Output
输出最少的权值

SampleInput
3
1 2 3
SampleOutput
9
Submit

#include <iostream>
#include <queue>

using namespace std;

priority_queue<int,vector<int>,greater<int> > que;

int main()
{
    int n;
    while(cin>>n)
    {
        for(int i=0;i<n;i++)
        {
            int x;
            cin>>x;
            que.push(x);
        }

        int res=0;

        while(que.size()>=2)
        {
             int x=que.top();
             que.pop();
             int y=que.top();
             que.pop();
             res+=x+y;
             que.push(x+y);
        }
        
        cout<<res<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值