HDU 1595 断边最短路

find the longest of the shortest
TimeLimit:5000MS MemoryLimit:32768KB
64-bit integer IO format:%I64d
Problem Description
Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn’t live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn’t konw exactly which road. It is possible to come from Marica’s city to Mirko’s no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.
Input
Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.
Output
In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.
SampleInput
5 6
1 2 4
1 3 3
2 3 1
2 4 4
2 5 7
4 5 1

6 7
1 2 1
2 3 4
3 4 4
4 6 4
1 5 5
2 5 2
5 6 5

5 7
1 2 8
1 4 10
2 3 9
2 4 10
2 5 1
3 4 7
3 5 10
SampleOutput
11
13
27
题意:跑1~n的最短路,如果断掉其中的一条边,求其最坏的情况(即走的最长的最短路)
思路:一开始还是跑一遍完整的dijstra,把最短路中经过的点记录下来,然后枚举断掉的边跑dijstra,从而得出最坏的情况。有些点与最短路无关的,也就是跑最短路的时候压根没经过它,就没有必要去枚举,不会对最短路产生影响,无用的点数如果过多地话可能会导致超时。其他具体看注释,点数不算多我用邻接矩阵建的图,下面献上我的low逼代码。

#include <stdio.h>
#include <algorithm>
using namespace std;

const int N = 1005;
const int M = 50005;
const int INF =0x3f3f3f3f;

int mp[N][N];
bool vis[N];
int dist[N];
int pre[N];
int n,m;

int dijkstra(int s,bool flag)///flag=1代表跑完整的dj 把点记录
{
    for(int i=1; i<=n; i++)
    {
        if(flag)
            pre[i] = s;
        dist[i] = mp[s][i];///把各个点到起点的距离直接赋值
        vis[i] = 0;
    }

    vis[s] = 1;

    for(int i=1; i<n; i++)
    {
        int maxx = INF;

        for(int j=1; j<=n; j++)///找没有经过的点并且权值是最小的
        {
            if(dist[j]<maxx&&!vis[j])
            {
                maxx = dist[j];
                s = j;
            }
        }
        vis[s] = 1;

        for(int j=1; j<=n; j++)
        {
            if(dist[j]>dist[s]+mp[s][j]&&!vis[j])///松弛操作 通过中间点实现缩短路径
            {
                dist[j] = dist[s]+mp[s][j];
                if(flag)
                    pre[j] = s;///记录点
            }
        }
    }
    return dist[n];
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1; i<=n; i++)///邻接矩阵建图 我老是忘记写这个 导致很多时候跑不出答案 看半天de不出bug是因为没写这个
        {
            for(int j=1; j<=n; j++)
            {
                if(i==j)
                    mp[i][j] = 0;///自己到自己的距离为0
                else
                    mp[i][j] = INF;到其他点都先视为无法到达
            }
        }

        for(int i=0; i<m; i++)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            mp[u][v]=mp[v][u] = min(w,mp[u][v]);///建立双向边
        }

        int res = dijkstra(1,1);///完整dijstra
        int ans = -1;
        int t = n;

        while(t!=1)
        {
            int k = mp[t][pre[t]];
            mp[pre[t]][t] = mp[t][pre[t]] = INF;///断边
            int cost = dijkstra(1,0);
            ans = max(cost,ans);
            mp[pre[t]][t] = mp[t][pre[t]] =k;///跑完之后恢复边
            t = pre[t];///接下一个点
        }
        printf("%d\n",ans);
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值