H Holy Grail(Spfa和Floyd)

As the current heir of a wizarding family with a long history,unfortunately, you find yourself forced to participate in the cruel Holy Grail War which has a reincarnation of sixty years.However,fortunately,you summoned a Caster Servant with a powerful Noble Phantasm.When your servant launch her Noble Phantasm,it will construct a magic field,which is actually a directed graph consisting of n vertices and m edges.More specifically,the graph satisfies the following restrictions :

Does not have multiple edges(for each pair of vertices x and y, there is at most one edge between this pair of vertices in the graph) and does not have self-loops(edges connecting the vertex with itself).
May have negative-weighted edges.
Does not have a negative-weighted loop.
n<=300 , m<=500.
Currently,as your servant’s Master,as long as you add extra 6 edges to the graph,you will beat the other 6 masters to win the Holy Grail.

However,you are subject to the following restrictions when you add the edges to the graph:

Each time you add an edge whose cost is c,it will cost you c units of Magic Value.Therefore,you need to add an edge which has the lowest weight(it’s probably that you need to add an edge which has a negative weight).
Each time you add an edge to the graph,the graph must not have negative loops,otherwise you will be engulfed by the Holy Grail you summon.
Input

Input data contains multiple test cases. The first line of input contains integer t — the number of testcases (1 \le t \le 51≤t≤5).

For each test case,the first line contains two integers n,m,the number of vertices in the graph, the initial number of edges in the graph.

Then m lines follow, each line contains three integers x, y and w (0 \le x,y<n0≤x,y<n,-10^9−10
9
≤w≤10^910
9
, x \not = yx


=y) denoting an edge from vertices x to y (0-indexed) of weight w.

Then 6 lines follow, each line contains two integers s,t denoting the starting vertex and the ending vertex of the edge you need to add to the graph.

It is guaranteed that there is not an edge starting from s to t before you add any edges and there must exists such an edge which has the lowest weight and satisfies the above restrictions, meaning the solution absolutely exists for each query.

Output

For each test case,output 66 lines.

Each line contains the weight of the edge you add to the graph.

样例输入 复制
1
10 15
4 7 10
7 6 3
5 3 3
1 4 11
0 6 20
9 8 25
3 0 9
1 2 15
9 0 27
5 2 0
7 3 -5
1 7 21
5 0 1
9 3 16
1 8 4
4 1
0 3
6 9
2 1
8 7
0 4
样例输出 复制
-11
-9
-45
-15
17
7

题目传送

当时题意理解错了,以为如果x、y之间存在路w,那y、x直接也存在路-w。
其实是要在x、y之间创造一条路(权值最小,因为不存在负权环,所以使环的权值为零,所以x、y之间的路是y、x之间路的相反数)。最后再把x、y之间的最短路加到mmap数组里。

dij算法不能处理负权值,三个最短路算法比较

FLOYD算法(时间复杂度较SPFA高,可处理负权值)
    #include<bits/stdc++.h>
    #include <iostream>
    using namespace std;
    typedef long long ll;
    const int inf=0x3f3f3f3f;
    const int N=305;
    ll mmap[N][N];
    int n;
    void floyd()
    {
        int i,j,k;
        for(k=0; k<n; k++)
        {
            for(i=0; i<n; i++)
            {
                for(j=0; j<n; j++)
                {
                    if(mmap[i][j]>mmap[i][k]+mmap[k][j])
                        mmap[i][j]=mmap[i][k]+mmap[k][j];
                }
            }
        }
    }
    int main()
    {
        int i,j,m,t,u,v,k;
        ll w;
        scanf("%d",&t);
        while(t--)
        {
            scanf("%d %d",&n,&m);
            for(i=0; i<n; i++)
            {
                for(j=0; j<n; j++)
                {
                    if(i!=j)  mmap[i][j]=inf;
                }
            }
            for(i=0; i<m; i++)
            {
                scanf("%d %d %lld",&u,&v,&w);
                    mmap[u][v]=w;
            }
            for(i=0; i<6; i++)
            {
                floyd();
                scanf("%d %d",&u,&v);
                printf("%lld\n",-mmap[u][v]);
                mmap[u][v]=-mmap[v][u];
            }
        }
        return 0;
    }

SPFA算法(时间复杂度比floyd低,可处理负权值)
    #include<bits/stdc++.h>
    #include <iostream>
    using namespace std;
    typedef long long ll;
    const int inf=0x3f3f3f3f;
    const int N=305;
    int mmap[N][N],dis[N],vis[N];
    int n;
    int spfa(int u,int v)
    {
        queue<int>q;
        int i,j;
        for(i=0;i<n;i++)
        {
            dis[i]=inf;//注意这里dis=inf,不是mmap,(mmap在循环中会改变)
            vis[i]=0;
        }
        vis[u]=1;
        dis[u]=0;
        q.push(u);
        int s;
        while(!q.empty())
        {
            s=q.front();
            q.pop();
            vis[s]=0;
            for(j=0;j<n;j++)
            {
                if(dis[j]>dis[s]+mmap[s][j])
                {
                    dis[j]=dis[s]+mmap[s][j];
                    if(!vis[j])
                    {
                        q.push(j);
                        vis[j]=1;
                    }
                }
            }
        }
        return dis[v];
    }
    int main()
    {
        int i,j,m,t,u,v,w;
        scanf("%d",&t);
        while(t--)
        {
            scanf("%d %d",&n,&m);
            for(i=0; i<n; i++)
            {
                for(j=0; j<n; j++)
                {
                    if(i!=j)  mmap[i][j]=inf;
                    else  mmap[i][j]=0;
                }
            }
            for(i=0; i<m; i++)
            {
                scanf("%d %d %d",&u,&v,&w);
                mmap[u][v]=w;//无重边
            }
            for(i=0; i<6; i++)
            {
                scanf("%d %d",&u,&v);
                int z=-spfa(v,u);
                printf("%d\n",z);
                mmap[u][v]=z;
            }
        }
        return 0;
    }
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值