F - Wormholes(判断负权回路 spfa)

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself ? .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2… M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2… M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1… F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
如果存在一个环(从某个点出发又回到自己的路径),而且这个环上所有权值之和是负数,那这就是一个负权环,也叫负权回路

#include <stdio.h>
#include <memory.h>
#include <algorithm>
#include <queue>
#include <math.h>
#define ll long long
#define INF 0x3f3f3f3f
using namespace std;
struct node
{
    int to,w,next;
} edge[9001];
int head[9001],cnt;
void add(int u,int v,int w)
{
    edge[cnt].to=v;
    edge[cnt].w=w;
    edge[cnt].next=head[u];
    head[u]=cnt++;
}
int n,m,out[4001];
int spfa()
{
    int u,v,i;
    int vis[4001],dis[4001];
    memset(vis,0,sizeof(vis));
    memset(out,0,sizeof(out));
    memset(dis,INF,sizeof(dis));
    queue<int>quee;
    quee.push(1);
    vis[1]=1;dis[1]=0;
    while(!quee.empty())
    {
        u=quee.front();quee.pop();vis[u]=0;
        out[u]++;
        if(out[u]>n) return 1;//入队次数超过n存在负环
        for(i=head[u];i!=-1;i=edge[i].next)
        {
            v=edge[i].to;
            if(dis[v]>dis[u]+edge[i].w)
            {
                dis[v]=dis[u]+edge[i].w;
                if(!vis[v])
                {
                    quee.push(v);
                    vis[v]=1;
                }
            }
        }
    }
    return 0;
}
int main()
{
    int T,w,i,s,e,t;
    scanf("%d",&T);
    while(T--)
    {
        memset(head,-1,sizeof(head));
        scanf("%d%d%d",&n,&m,&w);
        cnt=0;
        for(i=0; i<m; i++)
        {
            scanf("%d%d%d",&s,&e,&t);
            add(s,e,t);add(e,s,t);
        }
        for(i=0; i<w; i++)
        {
            scanf("%d%d%d",&s,&e,&t);
            add(s,e,-t);//时间减少t是负数
        }
        if(spfa()) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值