F - Wormholes(SPFA+邻接矩阵)

F - Wormholes(SPFA+邻接矩阵)

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself ? .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2… M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2… M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1… F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题意:农夫john发现了一些虫洞,虫洞可以把你送到过去的某个点,可以理解为负权路,FJ的每个农场,由n块土地(编号为1-n),M条路,和W个 虫洞组成,FJ想从一块土地开始,经过若干路和虫洞,能否看到过去的自己。

思路:意思就是能不能找到一条负权回路,让时间可以倒流,用SPFA判断是否存在负权回路。

 

代码:

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <vector>
#include <queue>
#define inf 0x3f3f3f3f

using namespace std;

int a[505][505];
int dis[505*505];
int via[505];
int n,m,mm,t;

void init() // 初始化
{
    memset(a,inf,sizeof(a));
    memset(dis,inf,sizeof(dis));
    memset(via,0,sizeof(via));
    for ( int i=1; i<=n; i++ ) {
        a[i][i] = 0;
    }
}

int spfa( int node )
{
    queue <int> Q;
    dis[node] = 0;
    via[node] = 1;
    int cnt = 0;
    Q.push(node); // 把根节点push进去 
    Q.push(cnt);  // 紧跟着一个cnt
    while ( !Q.empty() ) {
        int u = Q.front();// pop要两个一起
        Q.pop();
        cnt = Q.front();  // 第一个是节点,第二个是松弛的次数cnt
        Q.pop();
        via[u] = 0; // 取消标记,容易遗漏
        if ( cnt>n ) { // 如果松弛次数大于n,肯定存在负权回路
            return 0;
        }
        for ( int i=1; i<=n; i++ ) {
            if ( dis[i]>dis[u]+a[u][i] ) { // 更新最短路
                dis[i] = dis[u]+a[u][i];
                if ( via[i]==0 ) { // 如果更新完没标记,push进来
                    via[i] = 1;
                    Q.push(i);
                    Q.push(cnt+1);
                }
            }
        }
    }
    return 1;
}

int main()
{
    int listt,i,j,x,y,z;
    cin >> listt;
    while ( listt-- ) {
        cin >> n >> m >> mm;
        init();
        for ( i=0; i<m; i++ ) {
            cin >> x >> y >> z;
            if ( a[x][y]>z ) {
                a[x][y] = a[y][x] = z;
            }
        }
        for ( i=0; i<mm; i++ ) {
            cin >> x >> y >> z;
            if ( a[x][y]>-z ) {
                a[x][y] = -z;
            }
        }
        if ( spfa(1)==0 ) {
            cout << "YES" << endl;
        }
        else {
            cout << "NO" << endl;
        }
    }

    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值