hdu2196 Computer (树形dp换根)

Problem Description

A school bought the first computer some time ago(so this computer’s id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.
在这里插入图片描述
Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.

Input

Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.

Output

For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).

Sample Input

5
1 1
2 1
3 1
1 1

Sample Output

3
2
3
4
4

分析:
这题学到了挺多东西

d[i][0,1,2]表示以i为根的子树正向最大,正向次大,反向最大
id[i]表示以i为根的子树最大流流向的方向,存放的数据是子节点编号
任取一个点为根dfs且求出d[i][0,1];
第二次dfs利用d[i][0,1]求出d[i][2];
答案即为max(d[i][0],d[i][2]);
具体操作看代码(带注释)
code:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
#include<vector>
#include<algorithm>
#define ze(x) memset(x,0,sizeof(x))
typedef long long ll;
const int inf=0x3f3f3f3f;
const int inn=0x80808080;
using namespace std;
const int maxm=1e4+5;
int head[maxm],nt[maxm<<1],to[maxm<<1],w[maxm<<1],cnt;
int d[maxm][3];//d[i][0,1,2]表示正向最大,正向次大,反向最大
int id[maxm];
int n;
void init(){
    ze(head);ze(d);cnt=1;
}
void add(int x,int y,int z){
    cnt++;nt[cnt]=head[x];head[x]=cnt;to[cnt]=y;w[cnt]=z;
}
void dfs1(int x,int fa){
    int m1=0,m2=0;//最大和次大
    for(int i=head[x];i;i=nt[i]){
        int v=to[i];
        if(v!=fa){
            dfs1(v,x);
            if(m1<d[v][0]+w[i]){//比最大距离大
                m2=m1;
                m1=d[v][0]+w[i];
                id[x]=v;//更新最大距离对应的节点
            }else if(m2<d[v][0]+w[i]){//比次大距离大
                m2=d[v][0]+w[i];
            }
        }
    }
    d[x][0]=m1;
    d[x][1]=m2;
}
void dfs2(int x,int fa){
    for(int i=head[x];i;i=nt[i]){
        int v=to[i];
        if(v!=fa){
            if(id[x]==v){//如果x正向最远距离经过v,说明正向次大距离不在这条线上,用次大距离更新v的反向最大距离
                d[v][2]=max(d[x][1]+w[i],d[x][2]+w[i]);
            }else{//如果x正向最远距离不经过v,说明正向最大距离不再这条线索,用最大距离更新v的反向最大距离
                d[v][2]=max(d[x][0]+w[i],d[x][2]+w[i]);
            }
            dfs2(v,x);
        }
    }
}
signed main(){
    ios::sync_with_stdio(0);
    cin.tie(0);
    while(cin>>n){
        init();
        for(int i=2;i<=n;i++){
            int x,y;
            cin>>x>>y;
            add(i,x,y);
            add(x,i,y);
        }
        dfs1(1,-1);
        dfs2(1,-1);
        for(int i=1;i<=n;i++){
            cout<<max(d[i][0],d[i][2])<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值