HDU2196-Computer

持续强化dp中……

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 31896    Accepted Submission(s): 4314


A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information. 


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
Sample Input
5
1 1
2 1
3 1
1 1
Sample Output
3
2
3
4
4

             这次找了一道典型的树形dp。求一个树中所有节点能到达的最远距离。需要用2个dfs。首先第一个dfs求出每个节点i在其子树中的正向最大距离(dp[i][0])和正向次大距离(dp[i][1])。因此还要标记节点i在其子树中的最大距离经过了节点j(即j是i的一个儿子)。我们可以知道建立的这棵树,i节点的最远距离只有两种选择:i节点所在子树的最大距离,或者i节点连接它的父节点所能到达的最大距离。所以我们只要求出反向最大距离(即i节点往它的父节点走所能到达的最大距离)(dp[i][2])就可以知道i节点在整个树中能走的最大距离了。反向最大距离求法:i节点往它的父节j点走,如果它的父节点的正向最大距离不经过i的话,那么反向最大距离就是它父节点的max(正向最大距离,反向最大距离)+len[i][j],否则就是它父节点的max(正向次大距离,反向最大距离)+ len[i][j]。ans=max(dp[i][0],dp[i][2])。

Code:

#include<bits/stdc++.h>
#define N 100005
using namespace std;
int tot,dp[N][3],head[2*N],id[N];
struct edge
{
	int vet,next,len;
}edge[N*2];
inline int read()
{
    int f=1,x=0;char s=getchar();
    while(s<'0'||s>'9'){if(s=='-')f=-1;s=getchar();}
    while(s>='0'&&s<='9'){x=x*10+s-'0';s=getchar();}
    x*=f;
    return x;
}
void add(int x,int y,int len)
{
	edge[++tot].vet=y;
	edge[tot].next=head[x];
	head[x]=tot;
	edge[tot].len=len;
}
void dfs1(int u,int father)
{
	for(int i=head[u];i;i=edge[i].next)
	{
		int v=edge[i].vet;
		if(v==father)continue;
		dfs1(v,u);
		if(dp[u][0]<dp[v][0]+edge[i].len)
		{
			id[u]=v;
			dp[u][1]=max(dp[u][1],dp[u][0]);
			dp[u][0]=dp[v][0]+edge[i].len;
		}else dp[u][1]=max(dp[u][1],dp[v][0]+edge[i].len);
	}
}
void dfs2(int u,int father)
{
	for(int i=head[u];i;i=edge[i].next)
	{
		int v=edge[i].vet;
		if(v==father)continue;
		if(v==id[u])dp[v][2]=max(dp[u][2],dp[u][1])+edge[i].len;else
			dp[v][2]=max(dp[u][2],dp[u][0])+edge[i].len;
		dfs2(v,u);
	}
}
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		tot=0;
		memset(dp,0,sizeof(dp));
		memset(head,0,sizeof(head));
		for(int i=1;i<=n-1;i++)
		{
			int x=read(),y=read();
			add(i+1,x,y);add(x,i+1,y);
		}
		dfs1(1,-1);
		dfs2(1,-1);
		for(int i=1;i<=n;i++)
			printf("%d\n",max(dp[i][0],dp[i][2]));
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

JackflyDC

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值