B - Bound Found(尺取)

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: “But I want to use feet, not meters!”). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We’ll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t.

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.
Input
The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.
Output
For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.
Sample Input
5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0
Sample Output
5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

题意:
给你n个数,q次询问,每次询问给出一个t,让你从中找出一个非空区间,使得区间和的绝对值与t最接近。

重点是区间的绝对值和t接近,所以我们可以用前缀和,然后对前缀和进行排序,对于一个左端点l,找出第一个右端点r,满足区间对应的值>=t,对于左端点 l 区间和绝对值最接近t的就在此时的r和r-1处中取,只需要在r在递增的过程中不停的更新最小值即可。

#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<math.h>
#include<iostream>
#include<vector>
#include<set>
#include<stack>
#include<map>
#include<queue>
typedef long long ll;
using namespace std;
const int N=1e6+10;
const int INF=0x3f3f3f3f3f;
struct Node
{
    int qzh;
    int di;
}a[N];
bool cmp(Node x,Node y)
{
    return x.qzh<y.qzh;
}
int main()
{
    int n,k;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        if(n==0&&k==0)
            break;
        a[0].qzh=0;
        a[0].di=0;
        int hj;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&hj);
            a[i].qzh=a[i-1].qzh+hj;
            a[i].di=i;
        }
        sort(a,a+1+n,cmp);
        int l,r,ans,minn=INF,al,ar,sum;
        while(k--)
        {
            int t;
            scanf("%d",&t);
            l=0,r=1,minn=INF;
            while(1)
            {
                while(r<=n)
                {
                    sum=a[r].qzh-a[l].qzh;
                    if(abs(sum-t)<minn)
                    {
                        minn=abs(sum-t);
                        al=min(a[l].di,a[r].di)+1;
                        ar=max(a[l].di,a[r].di);
                        ans=sum;
                    }
                    if(sum<t)
                        r++;
                    else
                        break;
                }
                if(r>n)
                    break;
                else
                {
                    l++;
                    if(l==r)
                        r++;
                }
            }
            printf("%d %d %d\n",ans,al,ar);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值