C - Can you solve this equation?(二分)

Now,given the equation 8x^4 + 7x^3 + 2x^2 + 3x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input
2
100
-4
Sample Output
1.6152
No solution!

求方程的解,无解就输出No solution!

二分法

#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<math.h>
#include<iostream>
#include<vector>
#include<set>
#include<stack>
#include<map>
#include<queue>
typedef long long ll;
using namespace std;
const int N=1e6+10;
const int INF=0x3f3f3f3f3f;
double del(double n)
{
    return 8*pow(n,4)+7*pow(n,3)+2*pow(n,2)+3*n+6;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        double y,l=0,r=100.0,mid=0;
        scanf("%lf",&y);
        if(del(0.0)>y||del(100.0)<y)
        {
            printf("No solution!\n");
        }
        else
        {
            while(r-l>1e-6)//因为计算机默认精度为1e-6
            {
                mid=(l+r)/2.0;
                if(del(mid)>y)
                {
                    r=mid;
                }
                else
                {
                    l=mid;
                }
            }
          printf("%.4f\n",mid);
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值